Slow transfer speeds

Hey all,

After getting my drive set up with little difficulty I tried transferring some files to the shared folder on my cloud. I did this by dragging and dropping the folders using the WD My Cloud app shorcut on my desktop. The first time I did this I was connected wirelessly. I tried to transfer 3.4 gigs of music (flac and mp3 files). Everything was chugging along well until I got to 1.2 gigs and everything stopped. The WD My Cloud app because unresponsive and I had to reboot the drive.

Figuring this might be an issue with a wireless connection I connected my computer to my network via ethernet. Transfer speeds seemed quite fast but again, the transfers froze and stopped after transferring a few gigs. 

I have a My Book 2 tb drive with a backup of my music. I tried connection this directly via usb 3.0 to my MyCloud drive and doing the transfer this way. It seemed to work but the transfer rate was so slow as to be unusable. Again, after a few minutes it froze and became unresponsive. 

Any thoughts? Am I doing something wrong or do I have a bum drive?

thanks,

Erik

Instead of using the My Cloud app, try transferring directly.  You can access the My Cloud folders by Windows Explorer or opening it directly using the Run command prompt (“windows key” + r or Start > Run) and typing: \[ipaddress]\

Hi tnynyn,

I tried doing it from the explorer menu and got the same result. Interstingly, I received this network error message 0x8007003B. It looks like there might be a problem with my network adapter. 

As a test, I just transferred 8 gigs of music from my wifes computer via ethernet. No problem so I think it might be something with my machine.

Update Windows and driver first, then try this hotfix if you are getting that error:

http://support.microsoft.com/kb/983620

Scratch that. I just tried transferring 20 gigs and got the same error from my wife’s computer. I’ll try updating the drivers but that hot fix appears to reference win 7 and server 2008. I’m running windows 8.1.

If you can, do a quick factory restore and test again.

factory restored. Transferred some files with the same result. Errored out after a gig. I also noticed that I got a message aon some of the files that they had some properties that would not be transferred and was asked if I wanted to skip or re-try.

Nothing to contribute to the OP, except to say that I’m having exactly the same issue and have tried nearly the same fixes. Painfully slow, and now it seems unresponsive. It disappears intermittently from wireless network lists, and the dashboard won’t load (or loads but shows dashes in some of the fields instead of numbers)…

I must admit this is one of the most frustrating products I’ve purchased in a while.

efaust70, the files that could not be transferred where probably locked (i.e. in use).  Try this, if you have two computers, connect it to the network with the WD My Cloud via ethernet and start transferring files.  If you get an error other than file in use, take a screenshot and post it up.

Demiurge,  reboot the device, make sure the LED is fully blue and try transferring files via ethernet.

Tnynyn,

Thanks for your recommendation. Actually I had considered that, but couldn’t - the dashboard wouldn’t load, and when I tried to do it with Quick View, then Quick View just became unresponsive also. I was unwilling to hard reboot by pulling the power cord for a while, because the activity lights on both the MyCloud and the USB attached Passport were blinking, and I was afraid I would corrupt one or both. But after a few hours I decided it was either hard reboot, or a hard boot out the window, so I chose the former.

When it came back, it was still quite slow with transfers, but all the data I originally asked it to transfer seemed to have made it (there were a bunch of extra folders that had not been visible on the Windows app previously). So that’s definitely progress, it’s working now and the files made it OK, it’s just that the system choked on it and required yanking out the cord.

Once again, thanks for your help!

This is EXACTLY what has been happening to me.  MyCoud 3TB, wired to TP-link gigabit router, cat6 wired to Mac OS machine.  Transfer of about 500 GB of movies, pictires and docs took me about a week on and off.  The transfer was ridiculously slow and hung every 5 GB or so.  I had to break down the transfer into little bits just to get the files moved.  very frustrating.

I updated the firmware, soft restarted the device, hard re-booted, quick factory reset.  NONE of these make a difference. 

The drive shows up intermittently on my mac, same with the PC running win 8.1.  then it disappears.  and getting them to show up again takes several minutes.  FOR EVERY FOLDER I try to open.  trying to see files several layers down is pointless. usually the drive hangs before you get there.

The big issue when i open the dashboard is that it never seems to finish updating the database.  Like it just cant handle the amount of data i gave it.  What good is a 3TB device if it can’t handle the transfer of 0.5TB???

Does anyone know if i can return this to the store where I bought it (office depot)?  Or am I at the mercy of the WD warranty?

Thank you so much if you can help!!!

Read somewhere else on here that you need to connect your mac OS via SMB… i will find the post and give it a high five… because it makes a WORLD of difference.  I’m still getting error messages galore and the dashboard will never complete a content scan, but at least now i can actually USE the files on the drive!

Going to try copying some more large data blocks now to see how it fares.  Perhaps i should reset the drive and start again as i suspect my original non-SMB interface has created small inconsistencies with the data (as it was constantly interuppted).  Also a big thanks to another poster who mentioned something about that particular issue (a high fivre for that post forthcoming as well :slight_smile:

I’m having similar problems. 

New WD My cloud 3TB, Mac OSX 10.9. 

Gigabit router and using the supplied cables. 

Max transfer speed 30MB/s

Transfer same file to windows xp fileserver on same network and router >90MB/s.

Also, every time I use the Finder to look at the files on the drive, it says “Connecting…” for a few seconds.

Mounted network drives on the windows fileserver - available instantly. 

I tried mounting the WD via samba but makes no difference. 

I’m really disappointed with this product at the moment.

My solution is in the subject, here is the background:

  1. Unpacked 4 TB WD My Cloud last week, put on home network to backup all PC’s using wdsmartware.

  2. Default install on first Win7 PC

  3. Configured WD Smartware to Backup continously

  4. Backed up ~ 500 GB - No problems, test went well, so onto next PC.

  5. Installed on second PC

  6. Configured WD Smartware to backup continously

  7. Backed up ~ 250 GB no problems

  8. Installed on thrid PC, backup contiously, 100 GB, (did so over night).

  9. Installed on fourth PC, backup continously, 100 GB unattended…I know it completed but not sure when.

  10. Notice slow DLNA server to android tablet…Hmm, what is going on.

  11. DLNA server became painfully slow on tablet.  DLNA server somewhat slow on PC, but perhaps that’s  “way it is”

  12. Installed on fifth PC, backup continously, PAINFULLY slow…This seems strange.

  13. Discovered how to log in to console via SSH   (My night job is a Linux slacker)

  14. ran ‘top’ , found apache2 hogging CPU 60 to 80% total.  That’s strange.

  15. shutdown apache2 via

                 WDMyCloud:~# /etc/init.d/apache2 stop

  1. transfer speeds back to normal!!

  2. start apache2

                 WDMyCloud:~# /etc/init.d/apache2 start

  1. transfer speed horrible again.

18 (a), (b), ©, (d), through (z).  Changed DLNA settings, shut off DLNA, shut off cloud access, rebooted, rebooted, rebooted, shut off all the stuff I could shut off, read through all the logs in /var/log, read the /var/apache2 logs, researched web, searched “why does apache2 use cpu on wd my cloud”, threw the kitchen sink at WDMYCLOUD

(BTW, did I mention that 4 of the 5 PC’s are turned on sitting ‘idleing’ on the network?  No backing up or other transfers)

  1. Went to each PC and ‘exited’ QUICKVIEW from tray

  2. apache2 process calmed down, almost no CPU cycles used.

  3. transfer speeds back to normal

22 uninstalled QUICKVIEW, transfer speed normal with 4 PC’s turned on.

  1. Turned on 5th PC, (with Quickview still installed), apache2 starts using CPU (~10 to 20%)!!!

  2. Uninstalled Quickview, apache2 ‘goes back to sleep’.

Conclusion:  Quickview seems to want to update "constantly’ and does so by asking apache2 (webserver) to give it information.  Apache2 is constantly responding to the requests.  Multiple computers = multiple requests.

Hey, WD software support DUDES! Try putting a WDMYCLOUD on your network and see what happens when you attach 10 clients with QuickView.  Watch what happens using top.  If your experience is the same as mine, you can send me a Starbucks card !

-Ben

1 Like

Heheh… Fantastic bit of work there. I’ve never once installed quick view (never saw the need.). That’s probably one reason why I haven’t seen this particular issue.

Thanks for posting!

Update: 

QuickView does not seem to completely uninstall when you uninstall it from the Add/Remove programs in the Control Panel.

When a user logs in, the tray application re-appears and apache2 starts nawing on the cpu.  Had to go to the C:\Program Files (x86)\Western Digital\WD Quick View directory and manually rename the file:

   WDDMStatus.exe

to

   WDDMStatus-DoNotRunOrElseSlowTransferSpeeds.exe

-Ben