Slow transfer speeds on 3TB Mycloud

I have 4 windows pc’s in my home so i bought a mycloud to back up some important files & share them between my pc’s.

So far i’ve had a few problems

  1. The WD smartware and desktop apps don’t always recognise my device, even when it’s plugged directly into my pc ethernet port, a reset of the mycloud normally fixes this.

  2. The transfer speed from any of my pc’s to the mycloud when hooked up to my router with ethernet is at best 3mbs, when i hook it up to a pc directly i get between 5 and 30mbs.

  3. sometimes while using the desktop app it will loose communication with the mycloud, i have tried different cables and 3 routers but still no joy, even when plugged directly into a pc this can happen.

  4. moving files between share folders within the device is extremely slow, 1mbs. Either using windows explorer or the wd desktop app. By comparision my 500GB My Passport can do this at around 70mbs

I thought this device would be fairly simple to use but so far i’ve spent most of my time trying to troubleshoot.

my pc’s run 3ghz core 2 quads, windows 7 X64 ( 1 runs vista ultimate x64 ) asus p5q pro mobos ect

  1.  Never used smartware, so I can’t help here.

  2.  That’s pretty bad.   Should be more like this:


  1. Don’t use the desktop app when you’re on your home network.

  2. Moving between shares is NOT the same as moving between folders.   Moving between shares requires the data to leave the Cloud, to your PC, then back from your PC to the NAS.   This is true of ALL NASes ever made.  Moving between folders is just a quick directory update with no movement of the actual file data.    And that is also fast on a NAS.

How the heck you are reaching those speeds,  I can move data @ 90MB/sec to my Qnap but to my 4tb MyCloud it tops @ 35MB/sec. Swapped cables,  same performance :frowning:

Well, those are READS, for one thing…  writes are slower…

Here’s testing a WRITE…


Oops, didn’t notice that :flushed:

… but still,  you do way better then me, can you keep that speed fairly steady? 




I have to look in to it but strangely the Qnap works just fine so I don’t  know what can cause this. 

Thanks for your feedback.

Good to see your drive is working well for you.

I still haven’t managed to achieve speeds anything like that.

For a while I was getting between 5 and 30Mbs between the MyCloud & my PC’s which was a big improvement on previous speeds. Maybe due to a firmware upgrade, not entirely sure.

Now however my device is totally unusable. I woke up this morning & tried accessing some data and none of my PC’s would connect with it. The LED on the front is a solid white light  instead of the usual dark blue & no amount or resets seems to change that.

Looks like I’m going to have to return it and just go back to using portable hard drives.

I was really excited about this product, it seemed like a really cool idea but my user experience has never lived up to what I expected.