Slow Transfer Speed



I have a WD 1 TB external drive. When i transfer data from my hard drive to the external hard disk, the transfer speed is very slow. For a data of 1 GB transfer, it takes around 15-20 mins. This becomes a tidious process as it takes very long time to transfer hugh datas.


Someone please help me for the same. Any suggestions on increasing the transfer speed are welcome. Your efforts are appriciated.



1 Like

I also have the same problem.  Initially the backup would stop with about 2GB left to transfer out of about 95GB.  I spent about 1.5 hours with tech support and although they helped me change a couple settings and make sure I have the latest firmware and SmartWare to date it has taken 25 hours to backup 95 GB…and I still have abt 1 more GB to go.  At least it isn’t stuck but my WD passport runs faster so am thinking it is the software???

I am running Windows Vista with 4GB of RAM and I made sure when I started the backup this last time I closed all unneeded programs and internet.

I’m assuming that you are using a USB connection for you external hard drive.

My suggestion is to make sure you have the most current USB drivers on your PC.  Not having this will slow down the transfer considerably.

Suddenly have the same problem too… 1Tb MyBook Home Essential…no matter whether its USB, IEEE or even eSATA the drive has slowed to a crawl. Tried to reformat but only got to 10% after 12 hours!

Switched to different PC…same issue.


Finding no solution or help for what seems to a growing problem with a lot of MyBook users I returned the drive for a warranty exchange.

I will say that once all the files (some 100GB) was initially backed up the drive is updating the new and changed files seemingly effortlessly.  Once the computer is running I don’t even notice a lag in functionality even though I have the software set to backup as when there is a change in files rather than when the computer is idle.

The USB driver does not seem to be the issue as I also have connected my WD Passport (1+ year old) to backup some of the same files and it did so in 25% of the time.

I have My Book 2TB with Dell Latitude D630. It transfers 3kB not 3MB. It takes more than 1hour to transfer 10 MB.

It’s just useless with that speed. Can anyone tell me how to fix the problem please?

Thanks in advance.

I have the same problem as well.  Has anyone figured out what the problem is?

My Book Essential with same problem as above. Drive is extremely slow at writing large files but small files copy quickly. I have even tried formatting the drive to remove all traces of “smartware” and it didn’t change anything, still slow. Hope there is away to fix this as I am losing patience with WD quickly.

I just started having the same problem with My Book Essential 1TB. Its just 3 months Iv been using My Book and was very much satisfied with it until 2 days back this happened. As soon as I found out that windows was takin too much time to show the folder contents I began backing up data back to my intenal hard drive and it took 7+ hours to copy 50GB of data. I did the SMART Test and it was ok but the Quick Test failed.

And why arent there any more solutions to this post…I means evybody’s ignoring this post. Even if i get a product replacement it seems this problem might occur again.

I just lost my trust with WD which I had in abundance before this problem occured!

Hello all

I have a 1tb WD essential and it works fine with my PC. It transfers at a decent speed (6gig takes about 4 mins). however, when i use it on my MAC, running OS X, it takes much longer. a 6 gig file takes an hour.

Does any1 know any ways to fix this? Let me know.

I had the same problem with my 2t elite drive. My problem was that the USB port was on the same bus that was also being used by my USB keyboard. Took 20 hrs to back up 50g. I switched the key board to another port and now it is doing the work in less than 2 hrs.  I found this out by checking with dell, my PC has 6 ports but they share some of the resources with each other. Don’t know if this will work for you but it might be worth a try.

any solution to this ? mine was working fine, transferring at the quickish rate it should be, then i re-partitioned it multiple times, using disk utility on mac osx 10.6 and now it’s incredibly slow.

I bought a new 1TB My Book Essentials yesterday. I am getting speed of around 20mb/s only.

I had tried my friends hard disk and i used to get around 30mb/s speed. Are the speeds i am getting fine??

I had seen benchmarks in some site. They got around 35mb/s speeds. Any solutions would be appreciated.


FIXED. I had the same problem with 2 of these 1TB My Book- super slow transfer. It took a bit of playing around but it’s fixed now. Simple (im using XP) - open device manager and find the the WD my book and update the driver- point it to the virtual drive (must be on) and the driver folder. It seems you have to do this for each usb port (or always use the same one).

I have tested the speed (and compared it to a different drive) before and after. All fast now.

1 Like

My transfer speed is 25MB/s on Windows 7 64bit. I don’t think it’s very fast, how much is supposed to be the trasfer rate?

I’m sorry to be naive, but I tried doing this with no success. Once I got into the device manager, I couldn’t quite figure out the whole ‘virtual drive’ thing, etc. Would you mind giving me step-by-step specific instructions on how to do this? I have XP as well. It’s so frustrating to have this run so slow, so I’m hoping if you walk me through it I can fix mine as well. Thank you in advance. 

the virtual drive will show up as another CD drive on your XP machine. just select that drive as for XP to search when you update the drivers.

As mentioned above…It’d be really helpfull if u give a step by step intructions for fixing the stuff.

Has nybdy else done it n worked?


     I have a 1TB and a 2TB WD Essential,

     at first I thought it was my old computer, even though I have been using a USB 2 card;

     but having read the Driver suggestion, I went looking, and found that the drivers are Microsoft, and they have date of 01/07/2001, driver version 5.1.2535.0, I am running XP-Pro

      I tried doing a driver update via the system hardware, automatic update, but it didn’t have anything newer; if I find a work around, I’ll post it here. but right now, unless WD  comes to our rescue with some information, we are SOL and have to live with this;

      BTW, they are slow regardless of whether WD software is installed or not;

      just did a test of 1gb, and it took 1.2 minutes to transfer to the 1TB, but the same file transfered back in 5 seconds ;( my hard drive is a Seagate 500gb 7200rpm IDE, not a SATA; ) something is rotten here;

      oh, and according to Sisandra the drives inside are SATA, so one would expect them to run at optimum speeds; so I don’t see it as being the drives themselves but a software problem; so I will keep them and keep working at a solution;



   Well, a few hours later, and here is an update;

   Control Panel / Systems / Hardware / Device Manager - WD Drive Management Devices - Driver:

Driver Provider Western Digital Technologies

Driver date - 06/03/2009

vs -

no update for this driver available according to windows;

Control Panel / Systems / Hardware / Device Manager - Universal Serial Bus Controllers

NEC PCI to USB Open Host Controller

Driver Provider Microsoft

Driver date - 01/07/2001

vs - 5.1.2600.2180

no update for this driver available according to windows;

I have been to several sites, (2 that volunteered to give me free driver scans, but lead to pay for dirvers) Microsoft at this page -;en-us;312370

and they are aware of a problem going back to pre Win XP before  SP 1, but they claim that this was resolved with SP 1

   I have done a rebuild thinking that would resolve the issue, and installed SP3 and nothing has changed; I tried a USB Key (4gb) and it is also having issues of speed similar to the WD drives, so I have to presume that the issue is in the USB NEC card, and software related; the card is 6 years old, so it is possible that this is an issue, as i have not been able to find drivers for it today; I was on the CNET site and they had old drivers similar to what I already have;

I am going to pick up another card, which comes with drivers, and will report back;

    part of my effort has been to install SiS Software Sandra and PC Wizard 2010; as well as to clock the various transfers with a stop watch program; notihng has changed;

      Time for a brew and some sleep - Cheers :wink: