Slow Transfer Speed (Mac -> My Cloud Home) & Connection Status Problem in Desktop App

I bought a my cloud home 8 tb some days ago.
Since then I am struggling with backuping all the files from my Mac to it because the transfer speed is under 1mb/s most of the time.
I have read through all related articles in this forum and tried everything:
i have a 2x 1gbit/s lan router (Fritzbox 7362 SL), upnp is enabled, automatic port is enabled
I even tried different methods to copy the files like drag and drop, rsync, chronosync and some more.
i dont want to use timemachine.

I only get ok speed when I drop really big files. But I have a lot of small files, which would take a week or so to backup.
I know It takes longer to transfer a lot of small files. But that long?

One thing I noticed is that in my mobile app I have local connection to the my cloud home, but on the web app on my Mac where I want to backup the files its on relay. is this normal ?

I hope there Is a solution for this, because I love the idea of backuping all my files and at the same time access them from everywhere. but with this speed its pretty much useless.

Please review the following article that explains the slow write speeds to the User Mounted Private share.

If the macOS and Mobile Phone are connected to the same Router as the My Cloud Home, then both should have a Local Connection. You can want to check the network connection on the macOS to ensure is connected to the same network as the mobile phone and My Cloud Home.


Thanks for the answer.
But as i said ive read everything related in this forum, as well as the “data transfer speeds” article.

i calculated my transfer speed and it takes 2,2 seconds for 1mb
how should i ever backup 5tb to the drive?

is there a chance it has anything to do with the relay connection type?
both devices (my phone and my mac) are connected to the same router.
is there anything else i have to configure? maybe firewall or vpn?

i should add that ive transfered files in the home network multiple times before between different computers and i ve never had speeds like that.

@plusma The Private User mounted drive is not meant for “backups”, but to store content that you wish to access remotely. Backups are designed to reside in the following paths on macOS, but they will not be available remotely.


When writing 2000 files (5 GB size) to the Private User space, you can expect write speeds up to 8 MB/s, but not always, depending of file types and content.

As a quick test, try pointing your backup software to smb://MyCloud-XXXX/Public and you should see an increase in transfer rates.

ok. its on local now, but i dont know why. thanks for the help!

@plusma … it seems that we buy the worst “nas” on the world… i have te same problem… 330GB took 26hours… :confused: notning like… useles thing… you have cheap synology nas for 200$ … only you need to byu separately is a drive

Hello, i have the same issue, connected to the same network, on my MacBook shows Relay but on my iphone shows Local…

Does anyone know the reason, or how to set both on Local?