Slow network transfer to usb-disk


#1

I’m experiencing extremely slow transfer speeds to any connected usb-disk.

Ive tried wired 100Mbit connection, I have tried wireless both 54Mbit and 270Mbit.

Ive tried several different wireless usb-nics.

Ive tried using several different usb-disks.

The result is always the same. The speed wont go above 1-1.5MB/sec. Sometimes even as low as 0.5MB/sec.

ALL the usb-network adapters have been tested in the same location on a computer and provides full speed.

ALL the usb-disks have been tested on a computer and provide full read/write speeds as expected.

I have tried lots of different settings in my router, but the speed remains the same.

I’m looking for ANY suggestions on how to get higher speed.

Transfering 4-8GB files at 1MB/sec just isnt an option.


#2

From what I’ve seen the problem lies in the implementation of the samba protocol in the WD TV live, that seems to give sluggish transfer rates when you move data using network shares. I’ve read in this forum some people that had success using 3rd party programs in their PC’s to speed up the transfers, in particular with a program called Teracopy.

I captured a screenshot of the task manager this morning, after playing a custom encoded sequence of a x.264 file at ~30 Mbit/s average bitrate, first thru TVersity (an uPnP media server) and then thru a network share, and while the first time the video played smoothly without skipping a frame, the second time thru the network share was unwatchable, taking almost twice as long to play with constant pauses. You can readily see in the graph that the transfer was “capped” at around 25 Mbit/s, so around 25% of the theoretical throughput of the network.

http://img197.imageshack.us/img197/8448/capturalv.png


#3

I was kinda hoping for a more proper fix/solution.

BUT, the TeraCopy thing worked. So I’ll just use that until WD releases a proper fix, if possible :slight_smile:

Thanks for the awesome advice :slight_smile: