Slow menus and having to pull the plug to fix


Had a wdtv live for a few years now and am noticing recently its really slow when starting up (2 minutes+) or browsing the menus after accessing films or youtube.
Often when ive been using youtube itll just slow right down to a crawl, in that you press a button and nothing happens for 2-3 seconds and sometimes nothing at all.  Only way is to pull the power cable out and restart. Its a daily occurence and is really annoying., ready to go and get a roku 3 but thought i`d try on here first for ideas.

Any suggestions. I have the latest firmware and its connected via a network cable to my router.


Hi pr1970,

Firstly I cannot take the credit for this advice, that belongs solely to ‘Mr-Wolf’ who has just explained this exact problem to me in another post.

This problem is believed to be caused by memory leakage from the YouTube App, I see that you’re experiencing this slow down after using it. Apparently this issue was introduced with the latest firmware update and so we are currently awaiting a fix for this but in the meantime there’s a pretty simple way of solving this for you…

If your WD TV Live is currently switched off? Pull out the mains lead from the back of the unit. This will release the memory which is still being hogged by YouTube.

If your WD TV Live is currently on? Press and hold the power button on your remote for around 5 seconds and the unit will power down fully (deep sleep mode). This will have the same effect and release the memory back to the unit when you turn it back on again.

To prevent this happening again, just power down (long press on remote) at each shutdown.


1 Like

You can read more on this and other issues regarding the YouTube Leanback Service in Mr-Wolf’s post found here:

You will not find the last bit of advice that I gave you above as this was sent to me via private message.

Thanks for that. Yes thought it was youtube related as my son has been watching it alot recently. I also had some warning messages about memory buffer usuage was at its maximum so had to reset.

Hi there,

If this post has now solved your problems please can you mark it as ‘Solved’  so it can help others with the same issue.

Likewise a Kudos star would be nice as I have not got any yet! Please also give Kudos to Mr-Wolf for bringing this to our attention and making life just a little bit more enjoyable. :smileyvery-happy:

Thank you.

1 Like