Slow file copy/move to PR4100

#1

I am having the weirdest issue with slow transfers to my PR4100 … and I do understand transfer rates :slight_smile: . My transfers are ranging anywhere between 1Mbps and 5Mbps. A 10GB video file is taking an hour to 90 minutes to transfer.

My setup is ideal. Core i5-8600K, 8GB RAM, Windows 10 Pro. Gigabit LAN, 120GB SSD. My router is a Linksys EA9500 and all 8 ports are Gigabit.

If I copy a 10GB file from my desktop to the PR4100 it will take up to 90 minutes. If I copy the same file to any other of the 3 NAS units I have … which includes a WD Sentinel DX4000 … the file will copy in under 5 minutes.

What really makes it weird is that if I take the same video file and place it on my laptop, I can copy the file to any NAS unit including the PR4100 at speeds ranging from 50Mbps to 80Mbps … all while wireless not wired.

I have been all through these forums and have tried everything with no luck … Just to name a few …
Pack up your WD
Before you RMA

If anybody has anything else to try I’d love to hear it. I have a case open with WD but I’m not holding out hope.

#2

Since both of my posts have been named on your Post, I’ll put my two cents in.

Lets start with the fact that network access and network speed has nothing to do with WD meaning that WD tech support with their scripted 40sec reboot will not solve your problem at all. To be sure, turn off cloud access as well as media servers like DLNA, iTunes Server and so forth so that your PR4100 isn’t bogged down with scans.

Since Network Troubleshooting has nothing to do with WD, you can forget about screaming about how bad WD tech support and their products are, after you RMA your WD device for the fourth time.

The second thing we need to clear up is making sure that when we say 80Mbps (Megabits per second) we are really saying 10MBPS (MegaBytes per second) which is reasonable for Wifi N as this is the practical max.

As a side note and when you have finally found your problem, you can get 40MBPS with Wifi AC which entails getting an Wifi AC router of which you can bridge it to your existing router by plugging an ethernet cable from your router to your new router using one of the local ethernet ports and not your WAN port. Google this on how to bridge two routers; remember to turn off DHCP on one of the routers as well as turning off Wifi on your old router.

The last thing is that even though you may have a Gigabit ethernet, apparently even today if you have any 100Mbps devices like printers, home security, lutron hubs (home kit) on the network the whole network could slow down to 100Mbps. If you do have 100Mbps devices you will discover this while troubleshooting your network.

To troubleshoot:

Remove all devices from your network and only have your PC/Mac and your PR4100, both connect by gigabit ethernet on the network. Map the NAS and copy a 1GB file to or from the NAS. It should take about 10 seconds which is about 80MB/s to 100MB/s. If you are getting 10MB/s then your gigabit router has switched itself to 100Mb ethernet, or your ethernet cable is Cat 5 which may not support Gigabit speeds.

Check if your NAS has a Green led at the ethernet port. If yellow that is indicative of a 100Mb line.

If you still cannot get a 10 second copy of a 1GB file, you might need a switch between your router and your PC/Mac.

Regardless you should have a switch between your router and your home network anyways which makes it easier to swap out the router when you need to do so by just yanking one cable instead of a plethora of cables that goes everywhere.

Once you have determined that everything is working between your PR4100 and your PC/Mac start plugging in your other devices.

One last fact. If you have both wifi and ethernet connected, sometimes your connection goes through wifi instead of the gigabit ethernet. So disable Wifi if you are using ethernet.

So that is it, I think.

Let us know how your case is handled with WD. I could be wrong about the network having nothing to do with WD with WD tech support magically giving you an answer that none of us here in Customer supporting Customer land realizes or expected.

Also if you RMA your device, let us know how that turned out for you.

Good luck.

#3

Ralphael thanx for contributing!

My apologies for my typo … I do mean MB/s … megabytes not bits.Capture

I did make sure I am Gig all of the way through but I didnt think to remove all of my other devices since my laptop worked well and the desktop (which is only wired) worked well with every other NAS i have. I will give that a shot when i get home tonight.

#4

I also forgot to note that I did turn off all services as well.

#5

good. You should expect 80 to 100 MB/s speed to your NAS via gigabit ethernet, about 40MB/s via Wifi AC, about 10 to 11 MB/s via Wifi N and 1 or 2 MB/s via Wifi g.

Use a 1GB file. Every other file the bets are off regardless of how you are connected. e.g. if you copy a bunch of photos, pubs, mp3s of small file sizes you might get 2MB/s over gigabit ethernet and that is because of the buffers, the file startup and so on; nothing you can do about it and it isn’t WD’s fault either.

So if you get 80MB/s on a 800MB file about 10 secs, then you are set. Every other measurement is moot as this is the max speed of your gigabit ethernet.

things to check.
PC drivers to support gigabit
cords
switch
routers

Copying 10GB should be about a minute and a half for a gigabit ethernet.

For Wifi, that is also another ball game as you have all the various Wifi types of which Wifi G can be taken down by the microwave.

So I always say test with gigabit ethernet first to ensure that everything is going top speed and you eliminated bottlenecks like switches, cables, routers, 100MB devices and so on.

Once you have a fast connection between your PC and NAS, then start troubleshooting your Wifi which may have to do with being too far, bad wifi, drivers and so on.

I don’t know if the PR4100 supports a direct ethernet connection to your PC as the single Bay My Cloud allows you to connect an ethernet cable from the NAS directly to your PC and you can map your drive that way. This eliminates all the middle men and you can test your speed copy. If you don’t get gigabit ethernet speeds then there is definitely something wrong on your PC side. Look at the light on the ethernet port on the NAS, is it yellow? meaning that you PC is connecting to the NAS at 100MB/s.

Just for your info, the above is just my mind wandering along the possibilities.

Good luck…

#6

How did you setup that Media (W:) drive? It seems you are moving your data through mycloud.com.

#7

Just to be clear, my laptop whether wired or wireless can transfer to the PR4100 at optimal rates. Approximately 40 to 50MB/s. At this point I am convinced it is a Windows issue on the desktop in dealing with the NAS.

I am not copying through mycoud.com. I simply mapped a network drive … \IP Address\Share

I will be ruling out the network tonight and if that doesnt work, I will be performing a full system restore on the PC in the hopes of clearing out the Windows issue.

#8

mea culpa and here I am going on and on about troubleshooting your network. Sorry. If your Laptop has optimal rates then your network is fine. It is just between your Desktop and PR4100 that you need to troubleshoot.

What window version are you using? @Bennor had a list of Window 10 problems and fixes. Since it is only your desktop, drivers comes to mind, cable, use a different router port.

I do suggest throwing in a switch between your desktop and the router. This has solved a lot of router-PC connection problems.

Lastly, the only other thing that affected network speed in the last couple of years was that SMB Signing fix.

That is it for my ten cents worth…

Good luck. Let us know your resolution.

#9

Check the UTP cable too.
Eventually use winscp / filezilla to copy over sftp.

#10

What SMB fix???

#11

At this point, I’m throwing up my hands. My belief is there is some weird incompatibility between my PC and the PR4100. There is nothing wrong with my network config … this is proved because the 2 other NAS units I connect to with the same PC, transfer at speeds of approximately 80 to 100 MB/s. I have updated drivers, ran Windows updates, modified the registry and modified the NIC.

I dont know what else to do …

#12

Laptop to PR4100 -> good
PC to other NAS -> good

so… check out these links to see what info can help you.

compilation-of-windows-10-methods-steps-and-solutions

troubleshooting-network-file-copy-slowness

very true. Perhaps try a switch between the pc and the PR4100?

SMB signing…

https://blogs.technet.microsoft.com/josebda/2010/12/01/the-basics-of-smb-signing-covering-both-smb1-and-smb2/

On my mac, I had to patch my Mac to turn off signing otherwise I get half the speed.

again … good luck…

#13

Just wanted to provide a quick update … My situation has magically resolved itself. I lost power to my home for a period of time and when the power was restored and everything brought back up, all was fixed and working as it should. So the moral of the story is kill the power … drastically. :slight_smile: