Slow data transfer between USB and internal drive on MyNetN900C

I have a WD MyNetN900C with a 2 TB internal drive. When I plug in an 8GB flash drive to the USB port and transfer files from it to the internal drive it takes hours. I have tried to transfer 500MB of files and the progress indicator says it is going to take 18 - 20 hours. The transfer speed is 18Kb/second. Is this unit defective?

Definitely too long, have you tried using another USB memory? 

I have not tried another USB flash drive.

The flash drive was being used because I was getting the same kind of transfer speeds from a wireless Windows 7 Intel i7 64bit with 16GB ram laptop and thought the problem might be the wireless. I transferred over 5GB from the laptop to the USB flash drive in a few minutes and then plugged it in to the N900C thinking it would be faster that doing it wirelessly. When I select one folder with a couple thousand files that total about 500MB it takes over 5 minutes just to calculate how long it is going to take. It then starts the transfer and fluctuates between 10 - 20kb/sec and says it is going to take 18 (or more) hours. I have tried to doing single files, multiple files, multiple folders and they all show the slow speed.

I have a Quickbooks company file on the drive in N900C and Quickbooks takes over 5 minutes just to open the file on the wireless laptop.

Something is not right somewhere.

I will be calling tech support this week after I get dug out of this snow from the blizzard. I’m sure that something is wrong with the unit.

I just thought I would try the forum in case there was something really obvious that I was overlooking or maybe an actual WD employee might comment.

Hi Craig,

Just to be sure : try the same but using a single large file (i.e. zip your files into one package). 

See if that improves things ! 

When I try to copy a Blu-Ray disc content, it starts with the “small” files. And it says that the copy process will take about 18 hours. But then the huge files are copied and after 45 minutes, the 40Gb are copied to my USB drive hooked up to the N900 (copy speed : 22Mb/s average). 

This is about the only positive side of my N900. Everything else is **bleep** on my system (SMB Sharing ; USB disk naming…). 




I can try a large 500MB file but will not hold my breath.

I would live with 22Mb/s but I am getting 18Kb/s not Mb/s. That is kilobits, not megabits!


Hi Craig,

I am well aware of that. 

When I copy files, if there’s a bunch of small files, I get crappy speed in Kbps. About 180 though :slight_smile:

If it’s a large file, it goes up to 22Mbps (which is more than satisfactory to me, more speed can only be achieved with NAS internat storage : I got 57Mbps copying files from the internal drive of my LaCie NAS with built-in hard drive !). 

Anyways, if that does not work, there’s probably a problem somewhere !



Hi Craig,

Just another question : do you have any NONE gigabit Ethernet device connected to your router ? 




There are no ethernet devices. All connections are wireless except for the temporary USB flash drive that I am using to move files to the internal drive.