Slow Connection from PC to WD My Cloud Device, 30kB/sec!

Slow Windows PC connection speeds, ~30 kB/sec!!!

I have two (3 & 4TB) WD My Clouds. The 4TB is used for media sharing and the 3TB is used for backing up my MacBook Air and Windows PC. My MacBook Air works flawlessly with both devices.

However, my Windows 7 PC does not function properly. I have a gigabit Ethernet card and gigabit router (Netgear R6200). When I try to transfer files I get connection speeds around 30kB/sec. I have bypassed the router and plugged each device directly to my PC’s Ethernet port with the same result. I believe I have isolated the problem to either my Ethernet card or the settings on my Windows PC. I contacted WD Tech support and they were unable to determine what is causing the problem. I have updated all drivers, disabled firewall with no improvement.

I have several other wired (LAN) devices that operate flawlessly with my setup (Smart TV, Xbox360, Apple TV, etc.) and communicate fine with my PC. I can stream music/video/pics from my PC to my Smart TV and other devices without any issue. I run a 25 ft. Ethernet cable to a WD 8 port switch for all the devices in my entertainment center. Again, I bypassed router/switch/firewall by connecting the My Cloud directly to the Ethernet port on my PC and I still got the extremely slow transfer speeds of ~30kB/sec. 

My network adapter is a Qualcomm Atheros AR8161/8165 PCI-E Gigabit Ethernet Controller (NDIS 6.20)

Note, I have connected the My Cloud devices to my MacBook Air using a USB to Ethernet adaptor (for large file transfers) and the devices performed flawlessly. 

Any help will be much appreciated,

Regards

have you tried changing the cable from pc to router?  Hard to beleive but there are dodgy cables :slight_smile:

Also, it could be some services running on your pc. Check task manager.

 Uninstall the driver for the network card in windows pc and reinstall.

Check Windows forum for similar issues.

Try these suggestions:

http://www.sysprobs.com/windows-7-network-slow

1 Like

Thanks for the suggestions jamalaya. I have tried several different cables and followed the suggestions in the link with no luck :frowning:

Any further tips would be much appreciated.

Thanks for the suggestions jamalaya. I have tried several different cables and followed the suggestions in the link with no luck  :cry:

Any further tips would be much appreciated.

So you updated all drivers,firmware on the nic and the router, if any? what about the internet? test it here www.speedtest.net. What do you get?

 You should get as fast as your ISP allows?

how are you measuring testing? what are you transfering?

1 Like

Do you have another computer? You could create a share on that other computer and copy files from computer A to computer B…

Just want to make sure this is a networking issue, not related to the Cloud.

Hi Jamalaya,

All drivers/firmware have been updated. I have Xfinity internet, 11ms ping, download 120Mbps, upload 1.29 Mbps. The 1.29 Mbps upload seems slow. I seem to recall averaging around 5-8Mbps upload in the past (I use speedtest.net a lot and I think5-8Mbps is what I typically ge although I could be wrong). I will run this test again later to test my upload speed.

I noticed the slow communication when I tried to run windows backup.The backup starts but I can never get past ~12% because the backup takes so long. Then I started testing the transfer speeds with ~6MB pictures, ~3MB songs, etc. I see that I am getting ~30kB/sec when I click more details in the file transfer window. I have also tested using the LAN Speed Test program (v 3.4.0).

Thanks again for your advice J!

Hi Etupes, I have a Windows and Mac laptop. I have connected both laptops to the MyCloud with an Ethernet cable and had no issues with the transfer speeds. I am only having the slow transfer problem with my Windows Desktop PC.

I have not tried connecting my Desktop to my Laptop. I will give this a try Friday afternoon or Saturday. Note in my original post I discussed the other devices that are connected to my network. I have no issues streaming movies from my Desktop computer to my TV. I bypassed all network hardware and connected the MyCloud directly to my PC and got the slow transfer speeds, i.e. I ruled out my firewall, router, and switch.

I did speak with WD and they essentially suggested that I buy another Ethernet card? I was hoping that it was related to a Windows setting and not a compatibility issue between my NIC and the MyCloud devices.

After I tested my internet connection on speedtest.net (per Jamalaya’s recommendation) I noticed slower than expected upload speeds on the Desktop PC that I am having troubles with. So I reran the test on my wireless Laptop and the results are below:

Results from speedtest.net:

LAN Connected Desktop PC (although my firewall shouldn’t impact this I still disabled it):

Ping: 14 ms; Download 121 Mbps; Upload 1.4 Mbps

Wireless Laptop :

Ping 22; Download 20 Mbps; Upload 8.2 Mbps

I ran the test several times on both my Desktop and Laptop and the results were fairly repeatable. Notice the upload speed on my wireless laptop is ~8x’s faster than the desktop connection.

So I ended up testing the transfer speed between my Desktop and MyCloud using an arbitrary 8MB file. The transfer was extremely fast when I “downloaded” (or copied) the file from the MyCloud to my Desktop. When I tried to “upload” the same file to the MyCloud device I got a transfer speed of 23kB/sec. The problem seems to be related to transferring data from my Desktop to the MyCloud, i.e. uploading files.

Is there a setting on my PC/router/etc that I should look into to address this issue?

As always, thanks in advance!

HI dlewis031

 

WD might be right. But before that, goto Device manager on your problematic PC.

In the devices list find your network adapter

right click on property and choose Advanced tab

 

You should see a list of options:

 

find Large Send Offload v2 (IPv4) option and if it is enabled, disbale it. and if you are using IPv6 do the same.

Try this option first: reboot and test again

 

Do the following as well which I did on my machine and it improved my speed

 

IPv4 Checksum offload - disable if enabled
Jumbo frame disable if enabled (mycloud does not support Jumbo Frames).

TCP Checksum offload disable if enabled

UDP checksum offload disable if enabled.

 

This should improve your speed overall. I shaved 2 seconds of my speed onf 7.5 Gig transfer. Not much but when you are uploading many gigs it is noticable.

and make sure the option “Speed & Duplex” is set to auotnegotiation.

 

Hope this helps.

 

HTH

 

2 Likes

Problem Solved!!! I am now getting transfer speeds of 50+MB/sec. I am not sure if this is typical for a gigabit connection, but it certainly beats 30 kB/sec!!

First of all, both the Large Send Offload v2(IPv4) /(IPv6) were already disabled. So I continued on with the next 5 recommendations:

  1. IPv4 Checksum offload - disable if enabled (had to disable)
  2. Jumbo frame disabled if enabled (had to disable)
  3. TCP Checksum offload disabled if enabled (had to disable)
  4. UDP checksum offload disabled if enabled (had to disable)
  5. Verified Speed & Duplex was set to autonegotiation (already set to autonegotiation)

So my last question: Are ~50-50MB/sec transfer speeds typical over a gigabit LAN connection?

Kudos Jamalaya!!! Thank you so much for continuing to offer suggestions and follow up with me!! It seems both my 3TB & 4TB MyCloud devices are working flawlessly with both my Windows PC and Macbook Air! Thanks again!

dlewis031 wrote:

Problem Solved!!! I am now getting transfer speeds of 50+MB/sec. I am not sure if this is typical for a gigabit connection, but it certainly beats 30 kB/sec!!

 

First of all, both the Large Send Offload v2(IPv4) /(IPv6) were already disabled. So I continued on with the next 5 recommendations:

 

  1. IPv4 Checksum offload - disable if enabled (had to disable)
  2. Jumbo frame disabled if enabled (had to disable)
  3. TCP Checksum offload disabled if enabled (had to disable)
  4. UDP checksum offload disabled if enabled (had to disable)
  5. Verified Speed & Duplex was set to autonegotiation (already set to autonegotiation)

 

So my last question: Are ~50-50MB/sec transfer speeds typical over a gigabit LAN connection?

 

Kudos Jamalaya!!! Thank you so much for continuing to offer suggestions and follow up with me!! It seems both my 3TB & 4TB MyCloud devices are working flawlessly with both my Windows PC and Macbook Air! Thanks again!

Happy for you.

Gigabit will give max 125 MB/s. But remember both ends are connected to drives, file size (smaller slower), file numbes, drives (SAta 2 or 3 etc) etc, drive speed (7200rpm versus 5400 rpm),  connection protocols even motherbaord drivers fro all the on board devices, and firmwars etc, all influence speed and Aliens :slight_smile:

1 Like