Slow Browsing Interface

I have a Live SMP… Actually 6 of these.

Running the latest 2.01.86 firmware.

SMP is hardwired.

All video is stored on a NAS also hardwired.

2300 AVI, MKV, and MP4 files.

Issue not tested on pics or music.

Video browser display is set to gallery view 

Im finding that when browsing through the videos folder, loading of the movie info is really slow.

ie: choose the videos menu–choose the shared NAS folder–hold next page on remote to scroll to the Movies starting with the letter K… Talk about SLOOOW.  Try doing it backwards once. from Z to A. Its almost worse.

Now, Ive discovered that somewhere around the P or R titles, it scrolls fast, but only for a short time.  I dont think its specific to the Letters but rather the number of titles before or after the last video file (A or Z).

So, as a test, I downgraded to v1.16.13 and the problem still exists, but its not nearly as bad.

I have also tried other WDTV devices and the issue ‘seems’ like its RAM related. As each device differs on how many movie titles/info is cached.  Yes, I read about the caching in these devices…

Anybody have an idea on a fix other than switching the display view every time I want to browse to a title.  Yes, I know I can search, but Browsing is where the issue is.

An alphabetical jump list (like  windows phone) would be a cool feature to add, but this post isnt about adding a feature its about fixing an existing SLOOOOW problem in the latest firmware specifically.

Anyone else?


It’s not a RAM issue… The WDTV is accessing an SQL database over the network to fetch the data.

It’s much faster to plug an empty flash disk into the USB port and reboot the box. That way it’ll store and access the database locally.

Interesting.  So the ML display is based on the uniondb.cas_* files rather than the wdtv.cas2 files, and the uniondb files will get put on the flash drive rather than the first share if you have a flash drive in when you boot?  Might be worth a try to see if there is any speedup.  I don’t find ML scrolling  “SLOOOOOW”, but it isn’t speedy either.  I would assume one should delete the uniodb files on the server before attempting to switch them to a flash drive?

Yes, interesting.  I am testing right now.  What puzzles me is, why does an older firmware visually page through faster.

I looked at/in the db files and found a ver of for both v1.16.13 and v2.01.86 so the sql lite hasnt changed.

Also, why would the box automatically decide to store the db files locally instead of on a network share.  Is there a way to tell this thing where to store the db?  That way, it would not be a guess as to where the db files are going.

Yea, I over exaggerated on the SLOOOOW. Its not terrible but v2.01.86 is way slower than v1.16.13 when the ‘next page’ button is held down.


So, after the test between both firmwares, using an empty flash drive plugged into the front of the WDTV. I get an empty result on the flash drive and the NAS box still gets the db files stored on it.

As another test, I copied the db files to the flash drive and deleted them from the NAS to no avail also.  The WDTV just recreates the db files back on the NAS.

Any other suggestions?  Remember also that I found that v1.16.13 scrolls quite a bit faster.  Neither ver really ‘loads’ images but the scrolling is alot faster in the pre ver.


Is the flash disk writable? The WD will write a database to EVERY device it access. That includes all NAS shares and all USB disks.

It’s odd that you’re getting nothing on the USB disk.

So I tried a flash drive in the SMP, and it apparently works as “tony” stated, since the uniondb file is not in the shares (so must be on the flash drive).  I deleted the .wd_tv directories from each share (with both my SMPs turned off), and then restarted one SMP, which recreated the .wd_tv directories in each share, containing wdtv.cas2 files.

As for speed, however, I don’t notice much if any difference when scrolling through the ML files.

Ah, I cleared the Media Library (while having the uniondb file on the flash drive instead of the shares) and it completely broke the ML–last content source removed and no longer able to select ML as a source.  Since I fairly often clear ML to get all file updates seen, having the uniondb on a flash drive is a no go.  In any case, once back to uniondb on (wired) shares, I see absolutely no speed difference scrolling through the ML.