Single .m4v movie won't play - How to debug?


#1

I have a new WD TV Live that I want to use as a movie player.  I have an external USB hard drive attached, and there are 6 Mpeg-4 movie files (all .mv4 filetype) on the hard drive so far.  5 of the movies play fine, but one of them won’t play.

When I try to play the ‘bad’ movie I get text that says: ‘No Audio Channel’.  The display at the bottom of the screen starts counting as if the movie is playing, but there is no video either.  The file is 2.6GB.

Tried so far:

  • I connected the USB external hard drive to a computer, the ‘bad’ movie plays fine on the computer.

  • I erased the movie file from the external hard drive and re-copied the movie file to the external hard drive.  It still won’t play from the WD.

Any other ideas ?


#2

I solved my problem…but I don’t really understand it.  I simply renamed the offending movie from .m4v to .mp4.  It seems the WD TV Live handles .mp4 better.


#3

It appears that the .m4v is the same as the .mp4. It just depends on what the hardware recognises. 

You can read all about here

http://en.wikipedia.org/wiki/M4V