Since Update to WD2GO 2.0 Not able to access drives

I have the My Book 2 TB and My Book DUO 6TB. Both were accessible on 7/10/2012 when I activated my new 6TB drive system. The update to WD2GO 2.0 killed that. I am not able to use any of the code keys provided by either system. 

I went to the Google app store and downloaded WD2GO Pro and I am back on line.

This is **bleep** when something is working just fine and the vendor goes and screws it up. 

My systems have the latest firmware. This is the fault of the vendor providing the upgrade.

I really love my systems when they work, so STOP #$%%^^$$ them. 

Did you re-pair them?   Or are you trying to use the old codes?

You don’t even need a code when you’re on your home network.  Connectivity is code-less and almost automatic.

Also, is your MBL / DUO up-to-date on firmware?  WD 2go 2.0 requires the latest firmware.

I have the latest firmware on  both systems. It only works now with WD2Go Pro.

I guess they will screw that up tomorrow.

Sorry I tried it all. Just a bad update in my opinion. Poor quality.

But you didn’t answer my question.

Did you re-pair them?  Or are you trying to use the old code?

I just deleted and re-paired my iPad 1 and it worked without issue.

Repair what codes. 

I deleted and recreated new codes several times and it never worked. 

[Deleted] in my opinion. Too much to change for something that was wonderful and worked without fail until this last update. 

What benefits did I get? I could see my data, access my drives and share with others. 

Leave well enough alone. 

Did that answer the question?? 

I am not going to try anything else since reverting back to WD2Go Pro fixed my problem until they #$%##% that up. 

This is not a fix, nor solve the problem…

Since I have no android devices, My wife just installed it on her HTC and had it up and running in less than three minutes. No code required.

Sorry for missleading you. This was the solution for me. I am now “Gun Shy” to try it again. I hope you find your solution. 

I had the same problem until I decided to download the wd2go pro app. They changed the pro version to free so it doesn’t cost. Try to download the pro and resync that one to your wd live. I think they changed the old app to only work with dropbox or some kind of glitch right now. Still trying to figure it out myself, but wd2go pro will fix issue.