Shuffle - not able to randomly play all my music

the shuffle feature for music only seems to work within one folder. For my WMA music that is a single album. I want to be able to have all my music randomly played. I notice some discussion on a forum from some years ago complaining about the same issue and someone from WD was saying the problem had been worked on and resolved.

Is that true? If so, how can I randomly play all my music?
(I have a WD TV Media Player bought today and upgraded to the latest firmware today.)

Hello,

Check page # 87 of the user manual.

http://www.wdc.com/wdproducts/library/UM/ENG/4779-705123.pdf

It says:

“Use this option to set the audio tracks in the current music folder/playlist to play in random order.”

I had already read page 87.  It shuffles tracks within a single folder, ie within one album.

My question related to the ability to ‘shuffle’ across all my music tracks, effectively selecting all albums/tracks and having tracks randomly selected.

Your response seems to indicate that this is not possible, which is a great shame.

(also I forgot my password and despite asking to have this reset, I did not get the response email - and yes I checked the junk folder - so had to create a new user profile)

rz0jcm1 wrote:

My question related to the ability to ‘shuffle’ across all my music tracks, effectively selecting all albums/tracks and having tracks randomly selected.

Your response seems to indicate that this is not possible, which is a great shame.

 

It is possible :smiley: …

Setup > Music Settings > Music Playback Sequence > Shuffle

Then, go to where your music is, and press the  button on your remote control and select  Filter > All Tracks (see picture below)

Then select any song and press " ok or play" on your remote control and it will shuffle all your music tracks randomly.

(The “All Tracks” Filter ignores folder / album sorting … so the shuffle mode will be completely random across all tracks)

1 Like

thanks for that information. The ‘sort and filter’ function is not working for me. Is it supposed to work for network shares?

When I select music from the initial menu, it then lists the four network shares that I have on my WindowsPC and I select the Music folder. Media Library is turned ‘on’, but still not 'sort and filter.

You need to add your Network Share (for your music) to the Media Library for the “Sort and Filter” option to become available. eg. notice the picture above … the ‘source’ is ‘My Media Library’

Setup > System > Media Library > Media Library Manager for Network Share (and you will see the screen below)

Once you’ve added you music share to ‘The Media Library’ … from the Home Menu select “Music” then press the Red Source Button b.jpg

and Select My Media Library … “Sort and Filter” will now be available (via the Green Button)