Should I or shouldn't I upgrade to latest firmware 04.04.01-112?

Hi Folks,
I am basic home user of My Cloud and use it as a simple NAS with auto safe point back up’s monthly, a DLNA server for my smart TV and maybe once a week I access files remotely from my office. I am currently running 04.01.04-422 and keep getting email reminders to update my F/W however due to my mixed historic experience I am rather anxious at actually doing it.

My last 2 F/W upgrades seem to have worked no problem, however previous to that on upgrading my F/W my safe point back up wasn’t recognised, so had to manually drop and drag 1tb of data across, reformat the safe point but even that didn’t work. It was under guarantee so I got a replacement and after similar struggles (I still don’t know how it sprung back to life) I got it to work again.

So there lies my dilemma. Everything currently works on F/W 422 for me with no problems whatsoever. Should I quit while I’m ahead or potentially upgrade my F/W but play Russian Roulette with the outcome?

In case its relevant, I use Apple products like iPhones, iPads with the WD Apps, Home and Work iMac’s 2014 and 2015 macbook pro all using latest 10.11 El Capitan.


If the new features are of no particular use for your personal needs then I’d recommend keeping your current firmware revision.

You know the saying “If it ain’t broke…”

applies completely and wholeheartedly to WD firmware. If you are retired with nothing to do for a couple of weeks, upgrading will entertain you with challenges as you work hand in hand with WD Tech Support in the event your drive fails to boot up from the latest beta firmware.

  1. Wait a couple of months as the latest firmware settles when all bugs have been reported and fixed,
  2. then wait for the new firmware that fixes all the problems from the last firmware is issued.
  3. go to step 1 unless you have time to spare :stuck_out_tongue:
  4. upgrade firmware.

I was debating also but took the plunge yesterday which went without a hitch until I powered it up for the first time after the upgrade. It was stuck on a flashing white LED. I powered it up again, no change then another time but still no change. The pin hole RESET did nothing. I was about ready to try the pin hole hold with a power up but decided to post here. I almost finished composing it when I looked over and it had a blue LED. I guess that the first power up after the upgrade must be different? It’s been a while since out of the box new but wasn’t a long time for the first boot up normal?

My first upgrade last year to 3.04 was the same. That flashing white LED worried me and like you, I pulled the plug… (several times) then finally did a full 40 second reset and posted up on the forum… to find…

if it has the blinking white LED, leave it alone… don’t pull the plug… don’t reset it…

eventually if you are lucky… and for most of the time, it will turn back to blue.

It is actually Fsck’ing which is the same as chkdsk for windows and of course if you pull the plug on it… It starts all over… but this time it might have a few bad blocks because you pulled the plug… repeat this several times, there is a danger that it won’t return well from the fsck’ing and the light might turn red (just guessing).

Not sure when the blinking white light takes the longest but this is also one of the reason that I don’t power down my device too often for the fear that the blinking white light might never turn blue.

I do have a fw-upgrade-phobia…

I power down every night and up every morning.

I agree with Trancer. I needed to use new features and when I try to upgrade to new firmware, i had a bitter taste of things not going right for me. See my post on the current firmware not going right for me and I lost access to my cloud drive.

BTW, I use Apple devices as well such Macbook Pro, iPad and iPhone.

Glad you asked whether you should upgrade your firmware.

I power down every night and up every morning.

You shutdown via the Dashboard first, I hope…?

Whilst it ought to be able to survive unexpected power-out (because no electricity supply system or house wiring system will guarantee 100% power availability), doing it every day without doing a clean shutdown may be asking for trouble. At best, it may require a fsck process to run, which could take a long time; the blinking white light.

If you turn it off whilst there’s no write activity going on, it really ought to survive.

Nope! It’s on a power strip, shut if off every day for over a year and never had an issue except after upgrades.

so I waffled on whether or not I should reply to your daring lifestyle ways :stuck_out_tongue:

I mean, you probably could be doing this for the next ten years and nothing untoward will happen, but if I say something it would be like a jinx or a curse, and suddenly your Cloud takes a long time to boot up.

There is good news that you can recover from “MyCloud Solid Red Light”. when it happens.

I’ve done this when I first got my Cloud and after a firmware update when I couldn’t wait for the white light to stop blinking, I pulled the plug repeatedly after several minutes of waiting. Don’t ask me about the logic of all this, but I was frustrated you see and I ended up doing a 40 second reset, which resulted in a 3 hour fsck’ing the disk when I finally read on the forums to leave it alone.

Anyways, now that I started admonishing you and have already committed to pointing out to you that this might irreversibly corrupt your data, cross link all your files, cause WD to call you suddenly and to offer you an RMA, that this isn’t a great way of turning off your Cloud.

You can tell that this is the worse way “imaginable” to turning off your cloud by the blinking white light at boot up; it will take an increasingly and inordinate amount of time “fsck’ing” your cloud for file errors.

It is only a matter of time of when your Cloud will complain and not “if”,

but then again, it is your cloud, your power strip and I may be wrong (really)… carry on… :stuck_out_tongue:

I’m considering to do it correctly from now on, watch it mess up now! The manual states that it’s up to you to make sure that not operations aren’t being performed. I assume that power would have to be shut off to the MC and reapplied to get it to boot. Going to try this right now.

The LED is blinking yellow while it shuts down and still shows connected to my Gigabyte switch with blinking green on the rear. Turned the power strip off/on and It booted up normally. A bit more hassle than I’m use to though!

that is funny… I’m considering the opposite now… :stuck_out_tongue:

see “How robust is the My Cloud OS?