Sharespace causes internet speed to gradually decrease


#1

Hello everyone.

My setup (DHCP based):

adsl router (USR9108) <—>PC-1 (Win-XP)

                                          <—> Homeplug-1 (devolo)

                                         ^^^^^^ Homeplug-2 (devolo) <—>Access Point switch (100Mbps) ~~~~ Wii

                                                                                                                                                               <—> PC-2 (Vista) 

                                                                                                                                                               <—> Sharespace

                                        ^^^^^^ Homeplug-3 (devolo) <----> WDTV Live

where:

<—> is a cable connection on a LAN port 


^^^^ is a connection over powerlines

Everything worked normally before buying the Sharespace. When I bought it and plugged it in the access point I noticed after a while &nbsp;that I couldn't access the Internet, neither from the Wii nor from PC-2.&nbsp;

Rebooting the router (or reseting it via web interface) restored speed back to its maximum (~850kbps on a 8MB line). I then unplugged the sharespace from the LAN and the network &nbsp;maintained its normal speed (I left it unplugged for 3 days to be sure).

I then re- plugged the Sharespace and after 8 hours speed dropped again &nbsp;to ~90kbps. (I measure the download speed by downloading a large file from an ftp server AND by using speedtest.com). At this time I checked the LAN by streaming a 1080p movie from the NAS to both WDTV Live and PC-2. It worked without any problem, leading me to think that LAN speeds aren't affected.

Last night I disabled itunes server, MioNet, Network Time Protocol from the sharespace and reset the router (confirming that dowload speed resumed its normal 850kbps rate). This morning I checked again and speed was down to 80kpbs. I tried to disable the Twonky Media Server, but I couldn't find any way to do it.

Viewing sharespace's logs I noticed that in the CIFS tab, every 30 minutes there are the following entries:

2010/03/10 07:46:33&nbsp;&nbsp;Error writing 4 bytes to client. -1. (Connection reset by peer)  
&nbsp;2010/03/10 07:46:33&nbsp;&nbsp;write\_data: write failure in writing to client 192.168.1.7. Error Connection reset by peer

(I don't know if they are relevant to the problem). Please notice that 192.168.1.7 is the address of PC-1, so just in case I mapped a network disc to the sharespace.

I will get back this afternoon to see if that made any difference, but chances are that I will find a very low internet speed again.

Any thoughts?&nbsp;

I am thinking of borrowing another router to see if the combination of router / sharespace is the problem (since router is working perfectly without the sharespace in the network).

Upnp is disabled on the router.&nbsp;

It seems that sharespace clogs the router with something...

Thanks in advance

#2

After many tests it seems that this unit and my router (USR 9108) just don’t like each other!!

I changed the router and everything works fine. I use the old router without the NAS present and everything works fine. Old router and NAS, problems persist.

So, for some reason unknown to me USR9108 + WD Sharespace = problem.


#3

I saw your post, and passed your findings along.  I’ll let you know if I hear anything.