Shares vs Media Servers- Folders Missing


#1

OK I have a really bizarre issue and I’m stumped so I’m hoping that someone may shed some light on this and assist cause I’ve basically given up.

My Setup: Western Digial Sharespace (NAS) in one room on my LAN  talking to my WD Live Plus in my Family Room (pretty basic).

When the LIVE goes to " Video > Media Servers > NAS > Folder " I see the ALL Folder plus 5 folders under that and I can play from any of the listed folders, the issue is that I actually have 7 folders in the directory not 5 however …

When the LIVE goes to " Video > Network Shares > NAS > Public > Shared Video " I now see all 7 folders

I’ve checked all the folder permissions from PUBLIC all the way down to the down to the folders that work and the ones that are missing and all are the same 755.

I’ve tested creating new folders using FileZilla FTP and via creating a new folder in windows explorer and both yielded the same result, although the new folders are set to 755 the only ones that display in the LIVE are the original 5 and the other ones remain missing when viewed from the Media Server option.

I’ve tried rebooting the unit, logging on to the Shares folder with admin rights, changing the passwords, just about everything and I’m stumped.

Anyone have any ideas? I find it odd the in Media Server mode the new folders aren’t picked up when the Shares mode has no issue seeing them.

Miguel


#2

Have you posted this somewhere else?  I’ve seen you getting help with others.


#3

Not this issue, the shares v server topic comes up from time to time and Mike K has said it’s best to always go in from the share but I’m curious why it doesn’t update the folders listed on the server after a change is made. 


#4

HI. Try updating database of NAS…Media Servers menu is reading old database of files.


#5

razvanpas wrote:

HI. Try updating database of NAS…Media Servers menu is reading old database of files.

OK I’m in the NAS and in Twonky, rebuilding the database and re-scanning all the content directories. We’ll see later when this is done with the process if this alerted the Live to the new directories, in theory makes sense. 


#6

OK 1 word, bizarre! 

I went into the ShareSpace (NAS) and there is no option to rebuild the database to I moved into Advanced> Media> Media Server which brings up Twonky. 

From Twonky, using the PC Media Browser,  when I look at the shared video folder right there I see a problem, there are only 5 folders listed, not the 7 that are actually in that folder. When I move the Twonky settings and do a re-scan content directories as well as a rebuild database from the Maintenance menu neither seems to work to show me the missing content. 

I’m going to move this to the Share Space community and see if anyone has had this issue there, it’s not related to the Live it’s very obvious to me now that it’s specific to Twonky in the Share Space. 

Miguel 


#7

I just tested now on TwonkyMedia server 5.1

If i make an empty “New Folder” and rebuild database, it is not showing in media browser, therefore in WDlive not showing.

So a reason could be…

those folders to be empty or some unsupported media inside. Just test by moving some files from “invisible folders” to “visible folders” and if those files are playable. 

maybe you can find your answer here after all :stuck_out_tongue:


#8

Hmmmm interesting… and viola!

Ok I did what you suggested and copied an mpg file into the iso directory that previously only came up in shares mode and not server mode and low and behold the mpg was there right after I re-scanned the directories. So now there is a JPG folder file and 1 mpg movie in there, the other 100 iso images don’t display but it does tell me that to Twonky only an MPG and possibly other movie files are valid and ISO is not.

Incidentally the WD Sharespace that I’m running is still running Twony 4.4.9 despite taking several updates to the Sharespace over the year, WD hasn’t offered an update to Twonky and my limited shell knowledge (unless I have a really great step by step tutorial) is going to keep that from happening anytime soon.

So thank you my friend, I had scoured the web all day and seen where many people running Twonky had the same or similar issues but no body ever put their finger on the type of file that is in the directory as being the issue.

Lesson learned and again many thanks!

Miguel


#9

Im glad it worked out for you. Dont forget to mark the post as SOLVED!