Shared Videos directory GONE! please help

I was transferring files from within the Shared Videos directory and then later on I noticed that the directory was gone!
I tried restarting the device, it did a content scan and the Shared Videos directory reappeared but is empty, The UI ip address page says there is data still there in ‘other’ but I cant find it when searching for it. I’m very dissapointed in this product and it’s still under warranty. is there anything I can do to retrieve it?

Many thanks.


One way to see if the folder or data is really gone from the Public Share is to use SSH and navigate to each of the following directories and see if there is content within them:
/DataVolume/shares/Public/Shared Music
/DataVolume/shares/Public/Shared Pictures
/DataVolume/shares/Public/Shared Videos

One can use Putty or WinSCP to access their My Cloud via SSH. One first has to enable SSH within the My Cloud Dashboard.

If the data truly is gone there are various data recovery software programs one can run to try and recover that data, or one can contact WD or their recovery vender and return the drive for data recovery.

thanks for your help. I’ve enabled ssh and tried to follow instructions from this thread recover deleted files from wd cloud but as I have the new firmware it will not install testdisk and am unfamiliar with unix and ssh commands so don’t know how to search the directories and googling that at present.

I’m in root and when i type in ‘ls’ I get no response. just a new line to enter a command on. This tells me that root is empty and must be incorrect, right?

This tells me that root is empty


and must be incorrect, right?


Don’t look in root; it’s not your data system; it belongs to the NAS operating system.

Look in /DataVolume/shares

that’s where NAS user data is stored, as Bennor explained.


cd /DataVolume/shares/Public ls


ls /DataVolume/shares/Public

thanks it looks like the shared videos directory is empty.I used the command “ls -l”

I was planning on doing a recovery to an external drive. Is there any way to do this on the newest version of the firmware? Thanks

Spent some time reading up on different unix commands and can’t find anywhere the data may have migrated to.

I phoned Western Digital support and they said the drive is still under warranty until the end of this year (December 2016) BUT they can’t help and recommended me to seek data recovery from two companies which charge £395+VAT or £599+VAT.

Don’t think I’ll ever buy a Western Digital device EVER again! Can anyone help me without forking out more money than the drive actually costs?

Regardless whether you stay or go with something new. The one thing you can learned from this:
Always have 2+ copies for what you consider important files for you. This will protect you from hardware failure, software errors, user errors, etc.

Here is an easy to read doc…

I was transferring files from within the Shared Videos directory

How were you doing this? Is it possible you had ‘finger trouble’…?

I have to agree with Shabuboy: backups are essential; you never know when a storage device will fail, for whatever reason.

hmmm the files are still on the WDCloud as I can see them on the Twonky Server here:
(IP address of WD cloud):9000/webbrowse in the video options. This links to a page http://ipaddress:9000/disk/DLNA-PNAVC_MP4_EU-OP01-FLAGS01700000/O0$3$27I91403.m4v Very odd.

Can you still play them? Just because they’re still in the DLNA database, it doesn’t mean they’re still there… (Although since you’ve restarted it, twonky should have rebuilt its database, suggesting that, yes, the are still there somewhere…)

Which brings me back to the question: what exactly were you trying to do, and with what tool, when this happened.

Have you checked that you haven’t somehow moved the files into another folder or share?

Try this. SSH into the device. “cd /” Then you can run this command.
“find . -name *.mpg -print” This will display the location of any mpg file.
You can replace mpg with ts or any other file extention you might have
on your device. If the files are there his is the way to find them. Don’t type the quotes.


Yup; good call.

cd / find . -name *.mpg -print

I was going to suggest using the ‘By Folder’ view in Twonky’s media browser, as that should give the path (relative to wherever Twonky has been told to look: the Public share, by default).

I was using the WD Cloud tool version on Windows 10.
Dragging a video file from Shared Videos to a folder within there called Television.
I’ll try the search file for mp4 as I had many converted videos from .ts to .mp4 there so should find something if anything is still there.



ok I did the search and it looks like a few files are on a backup of another computer on there that havent been deleted (basically duplicate files) so at least a limited few have been saved but not my latest dvd rips. WD support are now looking into the matter.