Shared folder download speeds very slow. My Cloud Pro PR4100

Im trying to share several GB by using the shared folder option in mycloud.com but people are only getting around 300 KB/s download speeds. I have 300 mbps upload and download speeds which should be giving a max theorical speed of 37.5 MB/s.

I have tried with people that have 1 gbps download speed with their ISP to make sure they are not the reason of the slow dowload speed.

Is this slow speed normal? Is it because the transfers go through the WD website?
If thats the case is there a way to setup direct transfer from my drives to the user?
Or would I have to setup some sort of FTP or SSH file transfers for faster speeds?

Thanks in advance for any help you guys can give me.

Alvaro

Hmmm… Are you being throttled by your ISP, or by one of your ISP’s peers? (That is harder to prove forensically, but can be done.)

Sometimes, the upload bandwidth gets “Prioritized” (ahem)— and higher consumption protocol types get downgraded to “Improve user experience for other users”. (EG, assure that the letter to grandma gets delivered promptly, or that your VoIP phone does not cough and sputter.)

My upload speeds are not been throttle by ISP since I can upload 1GB to google drive in around 30 seconds. And I’m the only person using this internet.

Missed what I mean.

See also, “Packet prioritization”
http://www.linktionary.com/p/prioritization.html

Essentially, your ISP says “Yes, we know we sold you 300mbit upload, but some traffic is more important than others, and we will degrade traffic we consider unimportant, to make traffic we consider more important get more access to the wire.”

Large file transfers grab the wire and hold it for hours. This is “undesirable” from the ISP’s point of view, as they want you to push your upload message and be done with it quickly. So, they prioritize things like google docs, email, HTTP-PUT, and VoIP (because of emergency services), and the like-- while downgrading things like FTP, Tunneled vlans, P2P transfers, and the like.

I guess my only option would be to try to setup FTP direct access and test what speed im getting through there?

Pretty much. Like I said, it is harder to prove, but totally possible.

The other option, the ISP’s peer is doing the throttling— ISPs connect to other ISPs using what is known as a “Peering agreement”-- they agree to allow each other’s traffic traverse their wires. However, they might impose certain restrictions on that traffic as it comes over. Such as the afore mentioned packet prioritization.

I have been digging in my NAS settings and in Cloud Access it says:

Connected (Relay connection established)

when ive seen in some tutorials it should say:

Connected (Port forwarding connection established)

Would this be the cause?

Could be. Is your router configured with suitable port forwarding rules?

I found out my ISP blocks my ports 80 and 443 which are the ones My Cloud uses to connect.

I had to set Manual ports in Cloud Access settings (In my case I chose 9080 and 9433) and then in my router port forward port 9080 to port 80 on my NAS and 9433 to 433. Both in TCP and UDP.

Now it says “Connected. Port forwarding connection established.”

Tomorrow (when someone is awake) I will test the download speeds but im guessing this will solve it since its not “relaying” through the WD servers.

Welcome to the wonderful world of ISPs not liking people uploading data. (aka, running servers.)

The whole “Port blocking” things is well known, and they have done that ■■■■ for decades now. (They seem to think that you need to upgrade to “Business” class service if you want to run some kind of server, because then they will charge you way more money.)

I hope the private use area ports you have assigned work well for your needs.

In addition to teh discussion above, if using the PR4100 you may want to see the dedicated subforum for the WD Pro subforum where there may be addiitonal information/discussions relevant to this issue. Generally the discussion in this subforum (My Cloud) focuses on the single bay My Cloud.

Hello friend, it worked for you …