Shared file problem

I’ve uploaded an Excel file into a colleague’s folder that I have access to.  I thought that only one of us would be able to read and write to it but several times now, when I try to save my changes, I tells me that changes have been made since I opened the file and that I have to cancel, overwrite the file, or save with a new name.  When I checked with my colleague, she said there was no indication that the file was already open.  When I called WD they said that’s how it is and it’s a problem with my operating system?? What am I missing here?


Since you opened the file and made changes if you want to save those changes you want to overwrite it. If you do not want to save the changes you made then you click cancel. If you want to leave it as it was but also save the changes you made then you can save it with a new name.



Thanks for the reply.  I do understand what the choices mean.  The problem is that if I made changes AND my colleague made changes, then no matter what I do the file will not incorporate both changes.  What I don’t understand is why are both of us are allowed to access the file instead of just one of us?  Shouldn’t the second person to open the file get a “read only” message?? 

Which of the two of you is the administrator.


The administrator can go into the dashboard and select the other, a user created by that person and change their access to the file. See managing users in the User Manual or User under Help in the dashboard.

I am the administrator.  She has full access to the file and so do I so that we can both work with it.  Once again, the problem is that if one of us is already accessing the file, the second person can also access it and work on it instead of getting ‘read only’ access.

So you want the other user to have read only access while you have the file open? Or you want to edit and save changes at the same time? If you want to make changes at the same time:

In Excel > Review > Share Workbook > Editing > check the box “Allow changes by more than one user at a time…”

Exactly!  I’m not sure which one I want (I didn’t know you could do both).  

Could you also tell me how to do read only access?  Would it also work the other way so that if she had the file open first then I would get read only access?

Thank you very much!

I have Windows Office Home and Student 2013 and you can open up Excel, click on the Help icon (?) or F1 key and type share into the search box then click search. Maybe you will find what you want to use and how to set it up.

How are you both opening the file? Directly from the shared folder on the My Cloud? 

Yes, it’s in her folder whick I have full access to.

My department at my company is having issues with this as well.  The company is in the process of moving from a regular shared drive to MyCloud so that employees could access files from home.  I am in Finance, so I am not sure the reasoning for MyCloud vs VPN, but apparently MyCloud was chosen as the best option for the company.

In our previous set up, we had several “Shared” Excel files that multiple people could access at the same time.  Everyone could make changes and save at the same time, yet Excel would save the changes made by all users.  Excel also notified you that someone already had the file open if you opened the file while someone else was working on it.  However, when opening the file through MyCloud, you are not notified of another user working on the file.  And, it seems like if multiple users have the file open and attempt to save their work, each user would overwrite other’s work.  Is there any way to work around this and make it act like a regular “shared” file?  The settings on the files are already set up as mentioned by tnynyn above.