I have installed the software on my laptop and my desktop. I cannot get the users set up or the admin name set up or changed. It just sits forever saying updating and doesn’t do a thing. HOW DO YOU SET THIS UP?

They do not make this user friendly at all!

the 1st user it has you setup becomed the admin user and the admin name is no longer used.

exactly what is “updateing”? there are a number of things this can be.

this can be extermly slow initially and after major changes, be patient

FYI, there is no additional software required for setup or local accesss and you may be better off without it. for configuration use a web browser to http://mycloudIPorName/UI, which is all the shortcut does

what is the status of the 3 LEDs? the front 1 should be blue before doing anything else and better to be blue for at least 30 minutes.

what firmware is it running? if it is 4.00xxxxxxx I would upgrade it ASAP, the early V4 was pretty bad

I’ve tried adding stuff before with no problems and then deleted everything becuase I think they were in the wrong place. I had stuff in the TimeMAchineBAckUp as I wasn’t sure where to put my folder like pictures, videos and files. So trying to start over.

There is nothing on the EHD. I tried from the website to change the admin name as well as add a user and it will let me type in a name but when I kit save it just says “updating…” and does nothing. 

Here is a screenshot of the firmware. I just clicked Update Now and it says “updating…” but afraid this will do nothing as that’s all it’s been doing when I try to save or change something. Yes there is a blue light on the box itself.

FYI, it takes awhile for images to appear

what type and quantity of files did you have on it? how long has it been since they were deleted?

As long as nothing is currently there i would do a system only restore (leaves data) or quick factory restore(deletes data) and start clean

personal opinion don’t use any of the default shares except timemachine & smartware if you use thoose backup programs

create shares, users & permissions as needed

Have no idea what the timeshare and smartware are? THey aren’t explained in the guide that came with so where to I put my files? like documents, photos, videos? I just want to backup my embroidery files, pictures, videos and pictures from my kids laptops (If I can figure out how to connect theirs) I thought this would work just like a regular EHD or Dropbox.

There is currently no files on the device. So how do I factory reset it?

I clicked on update firmware, the blue light is still on and my screen still looks like this 30min later:

try refreshing the browser, it may be done

timemaching is an apply backup program, if you are on windows you can delete or ignore this

smartware is the WD program to backup windows computers to the mycloud, if you use this it defaults to the smartware share and my require it