Settings & shares vanished

Just started my PCs up this morning, and some of the shares on my EX4 just aren’t showing up through Windows Explorer. In fact, different shares are visible on both PCs; and through the app all of the shares show up; but then just say ‘no loger availabke’ when I try to access the shares. Even though the setting is switched off, ‘TimeMachineBackup’ share has reappeared.

In the settings, none of my shares show in the list anymore (not even ‘public’, but TimeMachineBackup is there); all of my scheduled backups have vanished (all of them ran for the first time the night before last); the network & CPU stats on the main page are blank, and the self-diagnostic returns no results.

I’ve already rebooted the thing, most of my other settings appear unchanged. I’m getting really concerned about losing data; especially as I haven’t been able to gett he USB backup function to work at all.

A similar thing happened to me a few days ago.  Lost my Shared Pictures folder when trying to find it through Mac or PC or web access.  But photos are still there when you access by date through DLNA (through TV).  A corrupted Directory.  Support has asked me to reset, which I have done.  But nothing has changed.  Still no Shared Pictures folder.

is this issues happening with the latest firmware ? 1.04.04???

what did you do ?  could you please help us reproducing this issue ?

Yes, my EX4 updated to the latest firmware automatically. The following day I ran two manual backups then four or five automatic ones ran that night. The next day I tried to get it to do a NAS to USB backup but it just kept cancelling. The morning after all this, some shares became inaccessible while the default ones reappeared (I had removed all but ‘private’ through the web UI). I set it off copying the backups to my PC which worked just fine, even though on the other PC and iPhone app, all of my shares progressively disappeared.
Also to note is that I was watching videos from one share throughout the two days; early each morning my Raspberry Pi (running Xbian) scans the media for changes, and I have one of the shares synchronised with a folder on my PC in real time.
The main screen of the web UI still shows 4.15TB free out of 8 T, just the same as before the problem; so it seems the data is stil there.

are you able to acess your files using the web viewer ?

im seems that you triggered something but i dont know yet

your data is safe still

if you have a backup… even better

No, the web viewer (through the web UI’s ‘Apps’ section, right?) shows just those three default shares.
My backup only covers critical files of about 100GB, the other ≈3TB I don’t currently have space to backup. It’s replaceable, but I’d really rather not have to spend weeks doing it.
Also of note is that my internal backups (the queue) had gone from the web UI, and have now reappeared; and the system stats & health check now also show information not just blank space.

lets see if the staff can help you directly

yes i was talking about that section

A brainwave happened so I went fiddling with the Twonky Server. Although the shares I had set up are innacessible, the Twonky UI has allowed me to browse via ‘Volume_1’ to see the folders that had been shared. So I can definitely now see that my data is intact, just that the EX4 has decided to remove them as shares.

Edit: not only that, but the Twonky server is happily scanning, re-adding and streaming said media.

So good news this time ? I would continue to post here. Please keep us updated to improve the NAS

Well, not quite good news yet. It means I know my data is still there; but how can I get the EX4 to share it all again?

I tought that you could get the unit to scan all of it again.

Sorry my mistake

Lets wait for staff them

Thw twonky server is scanning it all back in, but the device itself still isn’t making the shares available to browse directly.


I just tried re-adding the shares through the web UI. Same name, same location. I started with one of the folders which I definitely have all of the data from (I was worried that making a new share with the same name might erase the existing folder) and thankfully all it did was just start sharing the existing folder & data again.


That was a risky move…

Glad it worked

Risky indeed; that’s why I started with a very easily replaceable share; But all the support I got from staff was trying to deal with an inability to connect to the EX4, which wasn’t the problem.