Setting up Storage Archive on LAN. No internet access - Win 7

Hello all,

If anyone could weigh in on this I’d be much obliged.

I have a large array of storage that needs to be stored into an archive.
We purchased a network switch and three of these EX2 Ultra’s to be setup in a closed office on it’s on network with a single Windows 7 PC.
i.e PC, 3x NAS connected together using just a switch.

I’m having trouble getting access to the shared storage whilst being disconnected from our business network.

It’s very peculiar.
With access to the internet, all folders can mount quiete easily as you’d expect.
When disconnected from the network, I can still access the browser dashboards for each individual NAS and make alterations but sharing does not seem to work correctly.

We do have an enterprise edition of Windows 7 installed, so tried the same thing using a bog standard Surface pro with Win 10, and we get the same problem. Inaccessible files when not connected to a network with ISP.

Has anyone tried this setup before?
Please don’t tell me the NAS drives can’t operate without some access to the internet?

I’ve been through the settings for share locations, within the browser dashboard and set them to be available on everything.

Please assist. Any help or re-direction to earlier posts would be much obliged.

Best regards,


Hey, are they within the same network range? Do they have static IP address? How are you trying to open the shares?

Hi lluna,

Thank you for the reply.

I believe they are in the same network range (will double check at work) but they’re not using a familiar range.
If I connect a router into the mix I can get 192.168’s. This failed to help.

I haven’t setup static IP’s. Should this be the direction I go?

I’ve tried numerous ways of connecting the shares.
Start menu and type

Using “map network drive”, using various http, etc examples

Using “map network location”

I’ve also tried using the IP addresses shown by the web dashboard. I.e \\public

The network shares mount on their own accord when connected up to the business network.
I think this may be happening because the ex2’s require a DNS server?


At the moment, I’m connecting these drives (and PC) up to a Switch that is not connected to the internet.

Should these be hooked up to a Router only?

Do they require internet access to become visible?