Setting up SSH access on Ultra

I am new to My Cloud and am trying to setup SSH. I have enabled it. My setup requires a fixed IP address, and that is working. But when I try to use SSH:

$ ssh sshd@
Unable to negotiate with no matching host key type found. Their offer: ssh-dss

What does that mean?

For future searchers…

It seems the WD only offers a low-security SSH connection. I was using mintty, which uses OpenSSH. They have disabled DSA keys: That page explains why, and what to do about it.

OpenSSH 7.0 and greater similarly disables the ssh-dss (DSA) public key algorithm. It too is weak and we recommend against its use. It can be re-enabled using the HostkeyAlgorithms configuration option:
ssh -oHostKeyAlgorithms=+ssh-dss user@

I got in using PuTTY, and based on that discovered the above solution. That option allowed me to do SSH using my normal tools.

Looks like it’s time for an upgrade to WD’s SSH.

Thanks for sharing, hope this helps other users.

It does not work for me. Someone can help me.

change the ‘user@’
im using pro that is sshd@
check the my cloud ip addr and user manual there have ssh id(ex: root, sshd etc…) after check change like that

If anyone out there is still looking for a quick SSH fix, you could use this package made by a user jayp and install it. Here’s his post, with the sshHostKey update:

Otherwise, you’ll have to continue typing this lengthy ssh -oHostKeyAlgorithms=+ssh-dss sshd@ command to do so.