Setting up My Cloud

Hello everyone.
I already have a My Cloud Home which works perfect and found this week, at the office where I work, one My Cloud.
I then decided to try to set this up so we can use it at our office (all the employees). I am since Tuesday trying to set the My Cloud up but, I don’t know why, I def. cannot. I go to mycloud.com, select to “Set up My Cloud”, I choose the My Cloud and a new tab opens and nothing happen (http://wdmycloudmirror/). It looks that something is missing in this URL. It def, does not work and this is for ALL the products, not only for My Cloud. Am I doing something wrong or is WD facing a problem that they do not know?
I need to set this up and I def. cannot manage to do.
Any help, please?

Thanks.

1 Like

Hello,

Please refer to the following KBA article: http://support-en.wd.com/app/answers/detail/a_id/3760/

2 Likes

that doesn’t do anything I’m having same problem the urls are not working

@zecavalieri I think you should try this http://support-en.wd.com/app/answers/detail/a_id/3760/. But its not working as well. I tried it many time but noting appears on the page. :slightly_smiling_face:

Thank you, Logan.
I managed to set it up now with the instructions given. Much appreciated for the help. :smile:

Dude, follow the instructions in this link: http://support-en.wd.com/app/answers/detail/a_id/3760/

It really helped me and worked.

I’ve tried that but everytime I attempt to connect to a page link for wdcloud off that page it won’t load the web page

if you have the MyCloud connected to your internet via cable (from the router), go to the Windows Explored and type this direction: //wdmycloudmirror

See if works.

I’ve already tried that it won’t load the page

I’ve also tried from my phone’s web browser and it won’t load the pages either

I never thought of trying Windows Explorer though I’ve only been using Chrome I will try it when I get home in a minute