Server motherboard died; need accesss to RAID1 Data

Hi. My office server, running SBS2003 stopped working. I believe the motherboard is dead.
I have 2 hard drives (WD1600JS) in a RAID1 configuration, but I have not been able to access the data.

I am NOT trying to reinstall SBS2003 or “save” the server. I figured out I can do everything in the cloud now.
What I need to do is enter one of these mirror drives, and pull out some files.

I have computers running Windows 10, Windows 7, Windows XP; also a Mac

I have tried to access the drive using an external SATA to USB connector, but can’t read the data

Any ideas?

Thanks in advance



Not sure if that’s possible since the drive were on a RAID configuration.

Have you tried using a data recovery software?

What about getting the a replacement for the motherboard?

Thanks for your ideas.
Fortunately I had an external USB drive where backups were being made daily. I had forgotten about it until you mentioned it. It took a lot of effort but I was finally able to access the data in the backup. Not as easy as you might think since the backup was made with NTBackup and this is no longer available in the latest versions of Windows. Although you can download and install it, getting it to work is not straight foreward
I have been thinking about getting an identical replacement motherboard, but I only found a used one in Latvia!
Thanks again

The same problem with NAS Netgear Ultra 2.
File system EXT4
R-Studio v6.3 was the solution.
Windows 10, i7
Scan of single 1Tb HD takes about 2h 50min. (Don’t forget to save scan info).
Good luck:)