Server 2016 Essentials on DS5100

I do not know about the raid. My box has been sick for years, says BIOS degraded. They said it should fix itself on reboots but never does. If I get a chance I will put it on the bench and look at it

I did eventually get RAID1 on the boot drives but it wasn’t quite as straight forward as I’d hoped. It’s not difficult, just rather time consuming. I never got the automatic creating feature working.

The same backplane hosts the boot drives as the data drive - it’s the same controller. I have never been able to get into the BIOS utility, even after specifically trying to load various Marvell EFI OROMS for other Marvell controllers. It makes me think the 94xx doesn’t have such a feature available, and it’s limited to 92xx or 93xx controllers.

What I did was create a Windows-To-Go installation of Server 2012 on a USB3 connected SSD. (You could use any old HDD or flash drive, but it will be much slower).
I booted the clean install from the WTG drive and installed what I could of the WD drivers. It will prompt you to go through the Essentials setup - but it won’t be able to complete. You can just leave this in the background as it doesn’t affect what you need to do.
Once you have the WD parts installed, you should be able to open the Marvell RAID utility and configure the boot drive RAID from there. Shut down your WTG instance, connect your installer and when you get to the drive selection you should see your new RAID1 array.

Coincidentally, I started having issues with the WD-specific version of the RAID utility in that it wouldn’t show me the option to create a new RAID array. In the end I had to find another version of the Marvell utility and drivers and install that on my WTG instance - that worked out fine for me.

My DS5100 (upgraded to 6100 internals) has been happily running ever since with a RAID1 boot drive - although on 2012R2 as I had issues with the fan speeds on 2016 and the TimeMachine support package doesn’t run on 2016 which I do use.

Mercy :slight_smile:

So then, if I’m understanding there is a single Marvell 94xx that controls all six bays (the two controlling the boot drive(s) and the four that comprise the backplane) and that we cannot access a RAID configuration utility as part of the regular BIOS startup (say like hitting f2, Ctrl-M or something easy like that).

So to get around that, we need to create effectively two installations(?) of Windows Server (insert flavor of choice here), one in which we install server, run the Marvell RAID utility under windows to create the RAID1, then back out and install again? I got lost on the second install…

:thinking:

As an aside – in BIOS is it absolutely necessary to set to RAID, or is AHCI preferred?

There may be a way to get to a Marvell prompt prior to loading any OS through means of the BIOS - but so far I have not found out a method to do so.

Correct in that you need two installations of Windows. The key point from this is the first one MUST be a Windows to Go installation (i.e. NOT using a SATA port - it uses USB3). You cannot create a RAID using the Marvell config tool for your current active boot drive.
The USB3 Windows-to-Go installation gets around this issue as the SATA boot drives will not be in use at this time.

The second installation is your normal Windows Server install - hopefully now on a RAID array.

I keep my BIOS setting set to AHCI, not RAID.

Nuts – it would be so much easier if we could just get to a Marvell prompt like most other on-board RAID controllers.

That being said – is there a “how-to” on how to use the WTG and also one for the Marvell config tool (I think I vaguely remember doing a WTG awhile back for a friend’s computer, but I’d appreciate more info on both).

Thanks again – this has been very informative (if not a bit disappointing?), but I think I’m close!
MM

There’s not really that much to say about WTG - it’s a Windows install on a portable device (typically a USB flash drive). There are some quirks to it - but we’re not going to be using it for much longer than an hour.

There’s a piece of software available called Rufus which is a disk formatting tool. It also has the capability to create a WTG directly onto a drive using a Windows Install image (and a large enough flash drive).
From there you just have to boot into it and install the WD components (drivers and RAID utility).
Open the WD RAID utility and it’s fairly straight forward how to create a RAID array, As ever - make sure any data disks as disconnected whilst doing this to ensure no mistakes are made.

@biohead how did you get the raid utility installed?

It’s included in the WD driver pack that was so kindly put together by @Gramps. Just follow that installation process and it’ll be there.

Could you kindly point me to it?

When I upgraded 2012 with 2016, everything slowed to a crawl and I’m getting the same results when I did a fresh install. Do you think following this (your steps above?) process will speed things up? I’m really concerned I screwed something up permanently. Even though things run, my virtual machines are so slow it’s unusable.

Check your thermals - I had huge issues with 2016 getting the fans to react and the CPU would throttle like crazy.
I never found a final solution for it - some times it would work, sometimes it wouldn’t. Clean install or Upgrade had the same issues.

The driver pack can be found in Post 3 of this thread: DS6100 Upgrade Windows (Clean Install), Increase RAM & 3rd Ethernet Port

Are you using performance monitor to check the throttling? When you said you never found a solution, do you mean that you never got it running stably or that sometimes after an install it would work and continue to work, and other installs it would just never work?

A combination of the WD Monitoring within the Essentials Dashboard - which showed the high temps and low fan speed - and task manager which showed the clock speed had dropped as low as possible.

I never found a solution in that some installs would work and other installs it wouldn’t - without pinpointing what the trigger was. That, and combined with the fact the AFP sharing doesn’t function on 2016 made me stick with 2012R2.

Ah. How did you go back to 2012? Unfortunately I don’t have the WD “version” of 2012 R2. Do you think the generic version from MS will work along with your 2016 procedure to get the WD utilities installed? Does that add the WD specific feature to the dashboard?

Wish I never did the upgrade. While I have backups with Veeam, they are BSOD when I restore it.

see if it will boot into safe mode

  1. Is to hold shift and press F8 repeatedly. I’ve heard this work and I’ve heard this doesn’t work so your mileage may vary.

  2. Boot to the Server 2012 R2 disc and you can select Troubleshoot and then Command Prompt. You type in the commands below and when you restart the server and get to the boot screen you won’t see a “press F8 for Advanced options” but press F8 anyway and you will be brought to the advanced menu.

bcdedit /set {bootmgr} displaybootmenu Yes
bcdedit /set {bootmgr} timeout 15

I do have a recovery image available - it was created using the original WD WIM file in conjunction with a custom boot environment so all the drivers were integrated. I don’t know what the legality is around sharing this though.

Have you tried resetting your BIOS to defaults, then restoring a backup?

If it’s still BSOD’ing, does it stay on screen long enough to determine what the error message is? As that will hint as to what setting is wrong.

@biohead @Gramps

I don’t know what happend, but now I can’t see my OS drive at all. I’ve reset my BIOS, disabled secure booting and booted to both a 2016 and 2012 USB key. When I try loading the marvel drivers and hide incompatible drivers is checked, nothing appears. When unchecked, I see the mvs94xx.inf

This is a total mystery, as I was able to load the drivers a few days ago.

did the drive die? Good connections?

@Gramps not exactly sure. At this point I’m going to do a cross shipment replacement and get my data off. I did one in Oct of last year as well.

I just ordered a Intel NUC and use that as my backup server and recoup my losses by selling the DS. Too bad it’s been so unreliable.

Wish I had read this thread before buying one at Auction. Thought if nothing else I could install Linux on it to make a NAS but even a live Linux does not see the drives to install on it. Maybe they need to be formatted first? I thought they were SSD boot drives but am sure they are are 2.5 regular HDD