Self-created problem with portable drive


#1

Hi,

I’ve made a silly mistake and I’m not sure how to go about correcting it.  I bought a WD My Passport Essential 250GB portable drive.  I put a few divx files and pictures on it so that I could hook it up to my PS3.  When I connected it to the PS3, the drive wasn’t recognized.  So, I did a little research and I read that you have to convert it from an NTFS to a FAT32.  I followed the directions on a site, Yahoo answers I think, that directed me to delete the NTFS partition and then repartition it to FAT32 with a software called CompuApps Swissknife.  So I deleted the partition, but when I downloaded and installed CompuApps Swissknife, it kept giving an error and crashing (apparently CompuApps Swissknife does not work with XP ServicePack 2).

So now when I hook up the drive to the PC, all I see is the WD Smartware (H:).  Before, there was also an (Drive I:) partition, but now it’s gone. 

Have I destroyed the drive?  I don’t care about recovering my files.  I just want the drive to be as was and able to work on my PS3.  Any help will be greatly appreciated!  Thanks!


#2

I recommend that you reformat your drive to the NTFS file system using your PC.  Unfortunately, we have no means of formatting it to the FAT32 file system.  We do make a line of MyBook and Passport “AV” drives specifically for use with the PS3, however.

WD KB #3865: How to install, partition, and format a WD drive on Windows (7, Vista, XP, 2000) and Mac OSX


#3

I can’t format it either.  That drive icon doesn’t show up in the disk management pane.  The only icon that shows is the one for the partition that has all of the WD software on it.  The WD software partition software has 640 MB that is fully used and doesn’t give the option for reformatting.  Other than that there is no other partition on the drive.  Please help.


#4

Have you locked your drive with SmartWare?  If so, you will need to unlock your drive before it will show up within Disk Management.  You can format it afterwards.


#5

Hi.

Well, if you want convert all drive or a portion of it, you will need to execute “compmgmt.msc” and manipulate your drive in “Disk Management” Section. But, into where I know (in Windows) you can’t format a FAT32 file system larger than 32 GB. So, if you want more than 32 GB FAT32, you can use some disk util or even use Linux to format it. I has the 2nd option and I have 130 GB in my My Passport 1TB for content sharing with PS3.

Good Luck.

PS.: If you see an option exFAT in format method, skip it. PS3 doesn’t recognize it.