Selected network SSID keeps changing

When I try to connect my WDTv to our wireless network I can see on the auto-search option the correct network, with full bars, along with many other nearby networks.

On selecting my network and entering in the password the next screen has my the selected network as one of the other neighbor networks.

Even when using manual mode to specify the exact network name and password the following screens always show a different network SSID than the one I inputed.

Changing the security type on my wireless router or even removing security entirely does not seem to matter.

Well, first of all, don’t remove security from your router.  If possible, reverse all changes you made to your router.

Find the reset button on your WD and press it in with an end of a paperclip for no more tha a second or two.  When you release it, you can see your TV screen indicating the WD rebooted.  If you can’t find the reset button, use the remote to reset to factory defaults within the WD on-screen menu.

Once rebooted, start over and try to connect unit to your router again.  If it doesn’t, report back here the results you got.  There is just no way you are connecting to a neighbor’s network unless that network has no security turned on.

I am definitely not connecting to a neighbor’s network, but it appears it is always attempting to.

I reset the router to factory defaults and tried again. Here is a more clear (I hope) explanation of what is going on:

1.“Select an Available Network”

    -My Network

    -Other Network

    -Other Network 2

    -Other Network 3


*I select my network.*

  1. “Please enter the network password”

*I enter my network passcode.*

  1. “Network Setup”

Wireless Network - Other Network




Automatic         Manual

Note that here the Wireless network it is displaying is NOT the one I chose in step one. In fact, it isn’t always the same one. Sometimes it will be “Other Network 3”, or any number of the other neighbors or even just an empty space.

Selecting automatic doesn’t work, which is no surprise considering my password wouldn’t work for the wrong network.

This same thing will happen if I manually enter my network’s name. When I get to the “Network Setup” step it will always have another network there that I did not choose.

My router is running:

802.11 Mode Mixed 802.11n, 802.11g, 802.11b 

Channel Width: Auto 20/40mhz

Security: WPA-Personal, WPA2 Only (AES)


My WD Live is running latest firmware as of yesterday (obtained using a wired connection).

Before going any further, tell us exactly what model WD TV you have.  Your message is in the “older models” olayer forum, but since yours sounds like it might be a newer one, you may have it .  It’s called WD TV Live Streaming Player.

I would check your SSID is made up of only standard letters and numbers with no spaces in between.

Check the same applies to your passcode.

SSID is one word, normal characters, no spaces. Same with the password.

Yea I clearly posted in the wrong forum…whoops.

Tourresh:  Hope you got back to this forum. 

My new, hi-end router says to use 20Mhz (for channel width) if experiencing connectivity problems.  So, try this setting.

For security, instead of AES, select a combo of TKIP+AES if possible.  If these help, great.  If they don’t, then reset back the way they were.

I’ll have to think more about this.  It does seem “weird”.  Hopefully, others will come by and pitch in to help.

Changing the encryption had no effect.

Tried changing to 20mHZ. It still seems like there is a bug where it continues to not display the correct network. During the connection process it said it was trying to connect to a neighboring secure network, but actually did manage to connect to my network this time.

It’s not the fastest connection, but it works and seems to be stable with file transfers now. Thanks for the help.

So, your system is working now?