Select Files to Restore - Disabled

I have a 1TB WD Passport. The backups run every night. In the past, I have been able to restore individual file backups from the WD Backup program. Today I opened the WD Backup program to restore a file, however when I click the “Restore” toolbar item, “Select Files to Restore” is grayed out/disabled. I rebooted my computer and still have the same issue. I opened the “WD Drive Utilities” and did check on drive status and not issues.

Any thoughts on why I would not be able to click the “Select Files to Restore”?


Are you able to access the drive manually?

Have you tried reinstalling the backup software?.

Yeah I can access the files on the drive manually, however the restore feature does not work. I tried to reinstall the software based after you mentioned it and still the button is grayed out/disabled.

I have the exact same problem. I am very frustrated by this and have not been able to find a solution online.

Having the same problem. It’s ironic that such a software fails.

Is there anything that can be done about it?

Hi, I also have the same problem, still no solution?

Same issue here. I use the WD Backup software on my WD Passport (2 TB) and create ongoing backups on my Windows 10 desktop PC. Sadly, the “Select Files to Restore” button is greyed out. I can restore ‘manually’ but that has its limits. What’s the deal?

Could it be that anti-Ransom Ware defences prevent file access?

I was able to resolve the problem:
(1) Removed the anti-Ransom Ware defence from all USB devices. That was a tick-box on the Internet Security software configuration.
(2) Downloaded and installed the WD Backup software anew.
(3) Changed the backup from hourly to daily.
I cannot be clear, yet, as to which of the actions overcame the problem, but overcome it they did. I will test adding back the anti-Ransom Ware defence later.

Hourly backups had been something of a nuisance when, in attempting a restore, I frequently ran into ‘Preparing backup’ messages.