Secure WEBDAV

Thanks for the followup. Just want to clarify something…your static IP for the EX2…did you configure that on the EX2 itself (via EX2’s web interface) or on your Linksys router via its own web interface?

I configured it on the EX2 itself via the web interface.

Just what I suspected. That’s not the way I was sggesting you to assign static IPs. The reason behind all your problems is right there!! Static IP should have been configured on your router - NOT on the EX2 itself. The router is the sole arbiter of the DHCP allocation…when you assign something in your EX2, you are creating a lot of headaches for yourself. No wonder you had to resort to editing hosts file, etc. That hosts file editing and a couple other things gave me clear signs that the static IP that you thought it was being assigned was not actually getting assigned. In any event, if you clear out all the IP settings from EX2 and just leave it to DHCP and then setup the static IP on your router, everything will work just the way it’s supposed to. I do not understand (not trying to talk down to you) why so many EX2 (and other WD NAS) users that I have helped in the past two years think that IP setting should be set in the ENAs’ dashboardX2. It causes more headaches than not…the router should be the ONLY place where IPs should be assigned…it is the router which ultimately decides what DHCP IPs to dole out to.

I wish I could report success but I got the exact same results. I had one EX2 configured with static via the EX2’s web interface and the other EX2 configured with a DHCP reservation via the router and still got the same results from both EX2’s. I rebooted all devices to make sure everything was working from a fresh start.

I think the reason most people setup a static IP via the EX2’s web interface is because the directions that come with the device tell you to do that. Also, DHCP reservations are fairly new in some of the routers and you had to set them up via the EX2’s web interface.

But if you think about it, the DNS resolution is occurring on the remote pc and then an IP address is being presented to the router. So from a router perspective there is no difference between my using a DNS entry or an IP address. The hosts entry is only appeasing Windows.

Hmm, that’s odd. I would have expected the EX2 with IP from router to have given you different results. I do not know why you got same results.

Actually, the instructions from WD recommend to configure the NAS as a DHCP, which is what I was suggesting too (letting the router take care of the DHCP allocation as it’s supposed to). But yes, they also provide steps to alternately set up a static IP on the NAS itself.

My current Netgear gigabit router that I have had since 2009 has had DHCP reservation. And my current ISP router that I have had since 2008 has had DHCP reservations all along (my lone static IP configured on my ISP router → http://i.imgur.com/SM0dGT3.jpg ). I have been doing port forwarding, DHCP reservation, etc. on my home routers for quite a while (actually port forwarding since 2001, but yes, DHCP reservation was not available on my 100 Mbit Netgear router RT314 during my DSL connection days of early 00’s).

Yes, I agree.

Well, if your solution helps others out, great. Others will benefit from at least one either the workaround I mentioned earlier or from yours…either way, they should find one that works.

After some further research and analysis I found the following support article from Microsoft.

In agreement with this article if I use a period in my hosts entry I still fail. An IP address also has a period in it and thus also fails. So if I use MC02 as the hosts entry all is fine but if I use MC02.com it fails. This article seems very on target with the error but the fix it recommends does not help me. The only way I can get it to work is to create a hosts entry without a period. (although I also did not go through the effort of setting up a proxy per the article)

https://support.microsoft.com/en-us/kb/943280

This is a snippet from that site:

“In Windows Vista, Internet Explorer uses the Web Client service when you use Internet Explorer to access a WebDAV resource. The Web Client Service uses Windows HTTP Services (WinHTTP) to perform the network I/O to the remote host. WinHTTP sends user credentials only in response to requests that occur on a local intranet site. However, WinHTTP does not check the security zone settings in Internet Explorer to determine whether a Web site is in a zone that lets credentials be sent automatically.

If no proxy is configured, WinHTTP sends credentials only to local intranet sites.

Note If the URL contains no period in the server’s name, such as in the following example, the server is assumed to be on a local intranet site:

http://sharepoint/davshare

If the URL contains periods, the server is assumed to be on the Internet. The periods indicate that you use an FQDN address. Therefore, no credentials are automatically sent to this server unless a proxy is configured and unless this server is indicated for proxy bypass.

Note A server can be indicated for proxy bypass either through the bypass list or through the proxy configuration script.

In this case, you are prompted to enter your credentials when the Web site asks for credentials. Even in this case, the security zone settings are ignored.”