Seagate 4Tb not recognised

Hi all,

I have a WD TV Live Streaming media player (v2.02.32?) and a Seafate 4tb external hard drive. When I plugged it into the WD TV box, it initially recognised a usb connection but then stopped doing anything with the drive. Disk Manager says there is no usb storage connected.

If I plug this 4tb drive into my laptop it is recognised.  If I plug another drive in, this is identified. I used to have a 3tb Seagate drive and that worked fine.

I have connected the drive to my laptop and run checkdisk but this makes no difference. I added a film to the drive and still nothing.  I tried formatting it to see if this might help but no joy. It is NTFS.

Can anyone help please?

Does this hard drive use a special partition configuration or drivers?

I m not sure, Trancer. I’m a bit of an amateur so I don’t know how to check. It must be something specific about its configuration as all other drives work. Or maybe it can’t handle the 4tb drive.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

Sounds more like a drive issue than the WDTV.  

I use a couple of Seagate (and WD) 4Tb external drives without any problems.

Worth plugging the drive into your laptop and running “Error Checking” or CHKDSK over it.  

I have done this in the past and it fixes issues of drives not being ejected correctly.

I’ve tried this, Phil. No joy from doing that. Also placed a folder on the root and placed the files within this but still it momentarily recognises a USB connection but stops there.

I tried contacting WD as per Trancer’s suggestion but they’ve been slow getting back to me.

I’m formatting the drive and, failing that, seeing if the retailer can help. Annoying as all other drives connect and have the wdtv files installed without an issue.