Seagate 3 TB Ext. HD: Lost Most of my Disk Space after plugging into Hub

I purchased the Hub today and updated to firmware version 2.08.13. I can’t remember which version was installed on the unit originally but I made the mistake of testing the unit out before updating the firmware, including hooking up a 3 TB Seagate external USB 3.0 hard drive. I read about the issues earlier this year with the Hub and external hard drives over 2 TB but forgot to update the firmware BEFORE hooking up my Seagate 3 TB HD.

Now my 3 TB hard drive only shows 746 GB total capacity.  The hard drive still works and I can access all the files (I only had 600GB used). I am in the process of transferring all the current data to another drive, then I will try reformatting to see if can get my disc space back. I’ve read the forum about the Hub causing corrupt data and damaged partitions on 3 TB hard drives but would losing disc space fall into either category? Has anyone else lost disc space and still had a functioning external hard drive or am I the first unfortunate one?

Thanks in advance

You are not alone my friend!   I had similar situation happen to me, with my 3TB drive.  It happened around the time I upgrade the firmware to the latest on my box…I went from 2.07 to the newest.

I ended up formatting my drive and  resetting my Hub to stock and upgrading firmware in stages.  It did the trick and I’m back in business!

I believe my problems started from me constantly unplugging and plugging my hard drive to my laptop (and yes I always tried to eject properly:)  ).   Now, I just copy over my network…it’s slower, but it’s more reliable!

Yes, well after transferring all my data to a backup my problem was solved by doing a quick reformat. I now have all 3TB  of disc space back. I reinstalled a couple of files to the hard drive then hooked it up to the Hub with no problems this time. I guess I should consider myself lucky.