Screen Aspect

I am streaming movies from my WD Wireless, through MyCloud to my iPad, then direct connection through an Apple connection, HDMI to my TV.
Everything works fine, the aspect is correct, but the picture on the screen is only about 1/2 sized.
What setting can I change to fill the TV screen, and still maintain the correct aspect?

Is your TV a Smart TV, such as a recent model Samsung?

If so, it may have a DLNA client built in, which you could use to directly stream movies from the MPW to your TV. My Samsung certainly works quite well that way. I connect my MPW to my home network, then the TV which is also on my home network can see it as a DLNA source and I can browse the directories, select a movie and play it. No issues with image size or aspect ratio. The Samsung DLNA client is fairly crude, but it works.

Also, I’m not sure if the My Cloud App can act as just a DLNA Controller, but if it can it should be possible to use it to connect to the MPW on your home network, and then send the movie of your choice to the TV DLNA client, rather than via the HDMI out. If the My Cloud App can’t act as just a DLNA Controller, then maybe you could find another App that does, and use it instead.

If your TV doesn’t have a DLNA Client (specifically a Renderer, which is what plays the movie) then you will probably need to find video output setting for the HDMI out on the iPad. But you will need to check the video resolution of the movie, and the capabilities of the TV, and see they match. Plus, you will need to check and understand what you TV does if it needs to upscale a HDMI input, and if it does it automatically. Lots of variables in a video delivery chain like that.

No! The TV is not a smart TV. In fact I am travelling overseas, so all the TVs I am using are different. That is why I am using an Apple AV to HDMI connector. The only settings on the TV are the aspect, which doesn’t help with the image only being 1/2 sized on the screen.

The WD My Cloud App on iDevices does not use the full-screen video API when an HDMI adapter is in use.   It only does “Screen Mirroring.”   And since the output is only 1600x900 (IIRC) you’ll see a smaller picture.  

No way around it other than to use a different app that properly implements full-screen-video mode.

BruceFloyd wrote:
In fact I am travelling overseas, so all the TVs I am using are different.

Ah. This was an important and missing bit of information in your first post.

It looks like Tony’s post has your issue covered.

Screen aspect ratios are basically the responsibility of the TV.  If it is not your home TV, you may have to just deal with it.  If your TV aspect ratio is correct, you should not have problems, but someone else’s’TV?  No telling what the problem is!  It could be set up incorrectly.