Schedule/Queue USB Backups


#1

Please include the scheduler under USB Backups similar to what is available under Internal Backups.  Ability to queue backups would be really useful to serialize backups. 


Scheduled Backup not allowed on USB Device
Firmware 2.11.140 Where is the 'Scheduled Backup'?
MyCloud Safepoint vs Backup
Backup to USB is taking hours... is this normal
Internal backups to private shares: not working
Missing Backup options in newer Generation V1 vs V2
Problem with safepoint
How can I schedule a Sync backup to run nightly?
How to make incremental, differential backups from NAS to external USB
Set time plan for Backupjob NAS to USB - MyCloud Gen. 2
How can I backup my My Cloud to my My Book?
#2

#3

Agree. PLEASE create a scheduler for USB backups.

Just just bougt a WD EX4 16T as primary storage (to replace my other storage systems) and only realized now that backups can not be scheduled. This is absolute absolute absolute critical for me.

Thank you,

David


#4

Fully agree…cant believe this feature is missing!!!  How can we locally backup our NAS if this isnt possible?  Please don’t tell me that the internal backup is a local backup!


#5

This is a MUST. I cannot believe that this basic basic feature is missing. If still in doubt, pleasa check out the competitors. They all have it. I am thinking to return the unt becase of that. This is what saved me last time my Buffalo Teraststion lost its brain. 


#6

Hi,

Is there any update on the release of this feature yet?

When do you expect to implement it?

Mattt


#7

Ad  my request for ability to schedule backup on USB from/to WD EX2.  Seems like main purpose of attaching USB drive to NAS is to provide a backup in case of NAS failure.  Don’t want to have to do that manually.


#8

This is a very important requirement, Please count my vote for this


#9

Here is how you can do it, provided you are moderately technical. You create the USB->NAS backup job as you normally would using the browser interface. When it runs in Linux (the actual OS for the NAS) the process looks like this:

usb_backup -a BackupJobName -c jobrun

The NAS provides the ability to ssh into it, so you can create a script with that in it and create a cron entry to run it on whatever schedule you like.

My entry is for my job “Full_Backup” is:

0 1 * * 0 /home/root/Full_Backup.sh &

which runs the backup every Sunday at 2am. Good lucjk.


#10

agree is a prerequisite for such a famous nas server to boast a feature like that


#11

extremely difficult, i cannot do it. Would you mind providing more detailed info? I run on windows 10. Thank you.


#12

Certainly it should allow scheduled backups, both from a My Cloud share to a USB drive, and also from a USB device to a My Cloud share. Please implement this.

@sjgray8, while it’s possible to use your method, the first message you get when you turn on SSH is “This will void your warranty”. In your words, “Good luck”.


#13

I got no such message enabling ssh. It’s a built in capability in the
firmware and the GUI.

Obviously tinkering with the linux OS it runs isnt for everyone, but if you
are capable go for it.


#14

This is the message one gets on the v4.x single bay My Clouds when they enable SSH. Note what it states; “Please note that modifying or attempting to modify this device outside the normal operation of the product voids your WD warranty.”


#15

I have the two bay mirror.


#16

Please add a GUI scheduling feature to the USB Backups.


#17

I just had the sub standard Gen 1 MyCloud which had a sometimes working Safepoint feature amongst other issues, replaced by RMA with a Gen 2 that doesn’t have a scheduled backup utility, just rubbish.

Unbelievable that there is no scheduled backup to usb - is this a back bedroom company or international brand?

If this is not solved by a firmware update soon I’m off to find another NAS, never to return to WD as a customer.


#18

Hi, I have the same problem with my new mycloud 4TB. To date, western digital, doesn’t have insert backup NAS to USB scheduling. On my old mycloud 3TB i used the Safepoint Function. But now it there isn’t, and i would like a similar backup mode. I tried to edit crontab file with your instructions. When i set the backup one hour forward to test it, runs. But when i set the nightly backup it doesn’t run, and when i go to see the crontab file, my instructions there isn’t. How can i fix my problem? Thanks.


#19

so you updated crontab then the update vanished?


#21

Yes, it is. Not immediatly, but after few hours.