Scan failed, cannot resolve problem

My WD TV Live SMP is connected to an Iomega Home media server 2tb disk, hosting directorys, TV media, movies, Pictures etc.

The WD TV live SMP is connected via ethernet & I can connect ok with the directories containing my media, I can play the media in both Media server & network share options…But when I try to complie a media library I get a message “Unable to scan this directory to compile the media library because it is set to read-only!”

How can this be, when I can write to the dir’s on the Iomega Home media server with both PC & Mac laptop, to put the media there in the first place & the WD TV live SMP has also it has written a .wd folder to the root of the dir!.. The files within the .wd dir are very small 5k to 512b’s & date & time stamp is when the scan is first requested, but the LED on the WD SMP flashes for hours without changing the timestamp on the .WD files.

What do I have to get this thing to work!..

If I Can’t resolve I’ll be going back to just plugging in my Macbook pro with plex as my media player of choice!

… Locheil

Turn off the wdtv (completely), then delete all .wdtv folders it created. I get that sometimes, this usually resolved the issue.

1 Like

Tried that but still not working!

Tried to scan again last night at 21:25, left it over night & when I look at the setup screen it still shows the time 21:25, yet it is now 10:46 !.. I presume it’s locked up / frozen & failed again!

did you resolve the issue.  I had exactly the same issue with my Iomega NAS.  Logged call with WD and Iomega.  I eventually found a fix/workaround myself.

No did not resolve the issue, took the unit back the the store & got a refund!

… very poor response from WD tech support.

Shame…  it’s actually a good unit when it works properly.  I will admit the support I got from both Iomega and WD was pretty poor…considering they are both market leaders at this sort of thing for the home user.  I work in IT so fathoming out something like this is bread and butter…there’s always a way!!!

I have run into the same issues with my Iomega NAS and have not been able to get it to work.  Could you post more information on your workaround please.


have a look at my post here

For some reason I can’t reply to that thread. I read that already but am still a bit confused as to how you resloved the issues by using symbolic links.  Did you create a link to the share and then share the link?  Any help would be appreciated.  I purchased two of the lives and all my movies etc. are on the Iomega NAS. 

thanks again.


I created a symbolic link to my NAS movie share on my win7 box inside a shared directory and I can see it from my wd tv live but I can’t add it to the media library because it is read only :frowning:  I tried to uncheck the read only attribute from the folders properties but that doesn’t seem to work either.  I’m really at a loss to how to get this to work and help would be appreciated.



Sorry for delay in replying What I did was create a Symbolic Link to the folder on my iomega drive that had the media in (well actually I created a few). Share out that folder (created by the symbolic link) on your Windows7 box (if you follow from pg 35 of the manual you can’t go wrong Point your WD TV Live at the share on Windows 7 box… and you will now be able to add to use media library function. Pete