SATA drive problem .. now not in BIOS?


#1

Hello All.

I recently purchased a WD 500G SATA drive (model WD5000AAKS) for my home built PC since I was running out of space!  The PC already has 2 older WD drives , both IDE running quite happily , 80G and 250G so this is my first venture into SATA land.

The drive installed just fine , Bios recognized it as did Win 7 x64 so I started to copy some files onto it.

Sadly after about a week the drive stopped , it no longer appears in Win 7 and , more importantly no longer appears in the BIOS!  I also tried the drive in a different PC running Win XP and the BIOS there doesn’t see it either.

I’ve tried all combinations possible in both PC’s with regard to ports and cables with no result , however a SATA DVD writer seems quite happy with any port and cables.

I also tried booting with Linux Mint Live CD to see if that helped , still no drive ,  also tried booting with a Data Lifeguard  boot CD but that doesn’t see it either!

It seems that this drive will have to go back to base , one other trick I can try is connecting with a USB to IDE/SATA Adapter which will arrive next week.

From searching around on the web , It seems this is not an unknown problem , getting stuck in ‘BSY STATE’ is a phrase I’ve noticed.

Are there any other tricks I can try to get this drive going again , or should I just write it off?

All opinions gratefully received as usual … thanks!!


#2

Just a quick follow up … I found this related post on the ASUS support forums … same motherboard …

http://vip.asus.com/forum/view.aspx?id=20100303112710921&board_id=1&model=M2N-E+SLI&page=1&SLanguage=en-us

Hello,

I have these very weird issues with SATA drives, the M2NE-SLI Mobo and Windows 7 installation.

I’m trying to install Windows 7 in a clean (just NTFS-formatted) SATA HDD, but, issue #1, the drive is not recognized unless the jumper for 150Mb/s (between pins 5 and 6) is on.

So I put on the jumper and now the BIOS acknowledges there’s a SATA drive installed. 

 Then, I tried to install Windows 7 via an installation disc (the DVD device is on IDE), but sometimes it doesn’t recognize a driver at all (the installation screen says “No hard disk was found”), and some other times when everything seems to be going OK, the process fails suddenly with a 0x80042405 error (I’ve read it’s a ‘Mounting the system volume failed’ error) leaving the HDD unformatted, so I have to format it again.

I’ve tried many approaches to the disappearing drive problem. Namely:

-Updated the BIOS to 12.04
-Disabled/enabled the RAID functions on the BIOS
-Changed the booting order (CD-HDD-Removable / HDD-CD-Removable)
-Checked and switched the SATA cable (both cables work correctly)
-Checked the drive with some utility to see if it wasn’t damaged (not damaged)
-Tried another SATA drive to no avail (healthy, also NTFS formatted - still disappearing)
-Checked the installation disc (installation in another PC succeeded)

This is driving me crazy. I’m not new to installing and reformatting, but I can say I ran out of ideas. Why can’t I see my drives unless they are working at a low capacity? Why are the HDD failing everytime I try to install the OS? Is it possible the Board is failing or this is some configuration problem?

Here are the specs for the computer:

Motherboard: M2N-E SLI (I’m the king of obvious)
RAM: 2 1Gb DDR2 667 Kingston tablets
Graphics card: Elitegroup 8400 GS, 512Mb, DDR2 64bit
Processor: AMD Athlon 64 X2 Dual core
HDD’s: Western Digital WD Caviar RE2, 500Gb / Western Digital WD Caviar SE, 250Gb.

Any help before I throw myself out of the window will be very much appreciated.

Thanks,
Toño.

Kind of a similar situation except OS is already installed on another drive and the SATA is being added afterwards in my case.


#3

Well I have now tried reading this drive with a USB to IDE/SATA adaptor and it still doesn’t work! … not even powering up as far as I can tell so it’s going back and I will try out a direct replacement.

My confidence in WD has taken a slight dent now though … A shame since the 2 IDE drives I have been using in the same machine have worked quite happily for years now!