Samsung tv dlna intermittently disconnects from live book

I haven’t been able to find a forum here that discusses this issue yet (maybe I missed it).  I’m having an issue where my dlna between my samsung tv and my book live is intermittently dropped while streaming media.  Sometimes I can watch a movie for an hour, sometimes only a few minutes before the media disconnects.  

I have a motorola modem/router-in-one attached to a switch to which both the book live and the samsung tv are connected.  A forum elsewhere seemed to suggest that there may be some benefit to creating static ip addressed for the tv and my book live.  This has not resolved the issue.

Is anyone else experiencing similar difficulties?  Does anyone have any suggestions that may alleviate this problem?  

Thanks in advance for your help.

I have a similar problem but it is not intermittently as it is a thorough disconnect or twonky/MBL won’t/don’t check if anything is connected.  Evidently MBL also don’t care if twonky is sending audio/video prior to shutting the data stream.

I had a previous posting about my AVR being able to get music for only about 2 hrs (now believe that it is around 100 min.) after the MBL bootup (I shutdown each night).  I was able to get several hours of audio streaming twice; but now have resorted to rebooting MBL when MBL disallow Twonky to send audios; sometimes I unplug the ethernet cable until the MBL led goes to red & then plug the cable back into the router.

It shouldn’t happen.  Now believe that the MBL OS implementation is faulty as the listening socket evidently times out, goes to sleep indefinitely according to what is in the “watch” tables.  The listing for the Twonky server disappears from my AVR which checks for servers ocassionally & updates the listing.

So, I may have a fix for this.  I’ve watched two movies uninterrupted.  I disabled ‘Hard disk sleep’ within the dashboard (settings --> system --> energy saver), and also disabled ‘Restart on NIC changes’ under the network settings on the Twonky configuration page (to get to Twonky config page, go to :9000/config).

I am having a similar issue… except I don’t have to even be streaming anything in order for the TV to disconnect. I can just be one step into the DLNA browser (where you choose all files, album, folder, etc) for about 10 seconds before it disconnects. The thing that pisses me off the most, it is was working without issue only days ago. And nothing has changed in between the time it worked and when it stopped working, firmware wise. I have added folders and files to the drive, but those folders/files were not shared. I’ve eliminated the wireless component of my setup, to no effect. I’ve restarted, rebuilt and rescanned multiple times, to no effect. I am now in the process of removing files from the drive in preparation for a bloody factory reset to see if that will solve the problem. I am getting very annoyed with this WD product and all the hoops that I’ve had to go through to getting it working as advertised. I’m this ] [ close to returning it.

Hi,

I have the same issues. I try to watch a movie on my Samsung Tv and after 10(!!!) seconds it disconnects.

Tryed static IP. Didn’t work.

Isn’t there any workaround for this???

Regards,

Mihaly

I get both of these issues:

1 - error while browsing through folders to media, fails back to beginning. generally each retry gets you few folders deeper.

2 - disconnects during playback, from both Samsung BD-C7500 and PS3, much more from samsung.

PS3 is connected to the same netger DGNG3700 router as MBL, and Samsung is via a switch connected to router. All wired gigabit. 

I just unchecked the reset server on network changes, as this is not frequent on my network. will see if that improves.

“I just unchecked the reset server on network changes, as this is not frequent on my network. will see if that improves.”

Tried it and it didn’t work :frowning: Some other idea?

rgds,

Mihaly

Same problem here. I will be watching a move and then Device disconnected error. Why can’t a company as big as WD make products that do what is promised? I replaced my router, I am on a Fios connection, so what gives?

WDXpress wrote:

Same problem here. I will be watching a move and then Device disconnected error. Why can’t a company as big as WD make products that do what is promised? I replaced my router, I am on a Fios connection, so what gives?

Did you try the solution posted by BCooper? 

I will try that, Thanks :slight_smile:

Hi,

I tried everything but still no luck.

Any idea?? The strange is that my WD Live worked for a week, but after that, again it disconnets.

NOTHING changed.

I tried with different routers, static ip,  disable energy saving+ disable NIC restart but nothing helped.

So now I cannot use my wd live 3tb with my samsung tv because after 7 sec it disconnets using DLNA.

Any ide?

Rgds,

Mihaly

It seems that the MBL only has 8mb cache. So I also got the issue with the streaming interrupt. That was because of I got too many files on my drive. It tryed to get all file associations in the cache but overflowed at some point.

So the result was that the twonky client always trys to fill up the cache but if it overflows the client starts again…

Maybe u should try to erase or transfer some data from ur drive… 

I have around 16600 music files, 3400 pics and 1150 movie files on it with a cache use of 6.8MB

So there is not much air left…

Maybe this helps someone :wink:

greets

Not sure if Cache is the smoking gun.  This happens to me, too, using WDTVs and Twonky on the MBL…

Playing music, it can play for several hours without issue, or it can die as soon as 1-2 minutes after I start the music.

But one thing is for certain:  It WILL DIE, mid stream.

My MBL has roughly 8,000 music tracks, and is using only 3.3 MB of cache…

Well, it appears that in my case, if I turn OFF “Restart Server on NIC changes” option in the Twonky control panel, the problem goes away.

Same here…
Western Digital My Book Live 1TB
Twonky version 7.0.12-RC1 Special
Samsung BD-C5500 over wifi

Intermittent Device Disconnected issues.

Tried disabling hard disk sleep and restart on nic changes.

Hi all, Same problem here with My Book Live 3Tb disconnecting whilst streaming to my Samsung tv. Did anyone get a solution for this before yet another WD product flies out my window?

Seems as though WD is only good at making internal drives.

New Egg had a sale on Zotac boxes so I snatched one of them up and pointed it at the same NAS with no issues, ever.  I am blaming the Samsung Bluray.

Hi,

Same issue: Disconnects from DLNA Server when trying to stream using a Samsung Smart TV. My Book Live software version is the current latest (MyBookLive 02.42.02-012 : Core F/W). The media server software version is 2.3.0.12093

Hard Disk Sleep has been disabled. There are no other settings that I can find in relation to the NIC as per thread.

Has someone successfully resolved this at all?

Why cannot WD fix this issue? I 've been using Serviio in the past and it working like a charm! but have to have a machine on all the time for it to work… 

WD please help!

Thanks

Its same here, mybook live 2TB, samsung ES8000, gigabit wired (huawei router), WD DLNA server, both tv and WD latest firmware available. However I realised something, the disconnection problem occurs especially when the WD unit displays HDD activation (with no reason).

My only solution is, rebuild dlna server database, this causes two things, first, unnecessary disk activation stops (solid green, most of times) and no disconnection. Right after adding a file or two into WD unit, sooner or later it disconnects while playing via DLNA on TV. I do not want a hacking solution, I think this must be Western Digital’s responsibility to find a cure, or should I simply stay away from WD units… ?

It’s same here, mybook live 2TB, samsung ES6800, Cisco Linksys E1500 router, WD DLNA server, both tv and WD latest firmware available and both have a static IP.

Yesterday I installed WD Media server, I surprised that I can see subtitles now, after a year of bought my My Book Live! But, I can’t see a complete movie. The maximum time that I can see is 10 minutes, then the disconnect message appears on my TV.

I deactivate Hibernate of disc and TimeMachine Backup; but the problem persist.

Any solution?