Samsung TV Disconnecting when connecting Via DLNA


I seem to be having a problem with the WD Mycloud and my Samsung TV’s.  I have set up the WD drive and can access it from all my devices on my network (and outside of my network).

The issue is when I am playing a media file on my Samsung TV’s from the WDMC it disconnects when I am mid way through watching the video (Could be 5 minutes, could be 40 minutes).

Now this has happened on both TV’s and also doesn’t seem to matter if it is a small file or a large file, and seems to do it anytime.  I purchased this product for this use so having it not work as it is supposed to is very frustrating.

The TV’s are hard wired and wireless and neither seems to make a difference.  I have the 6 series models (6640 and 6400) 40 inch.

I have switched off the eco mode (hard drive sleep) also switched off UPnP on my router, and set the WD device as a Static IP address to no avail.

Are there any suggestions as all the advice I have been given seems to lead to no where.  Everything is hard wired and issue persists, but when I use my android phone, tablet or ipad it is fine and no drop outs and it works perfectly as it should.

Please advise.


Log into the Twonky user interface:

and go to Settings, Advanced, and UNCHECK “Restart on NIC changes” (or whatever the phrase is) and SAVE.

See if that helps.

1 Like

Thank you for the quick reply Tonyph12345.  I will try when I get home from work and report the results.

I was having the exact same problem with my Samsung TV…it kept disconnecting while watching videos from my WB My Cloud at random times. What fixed it for me was updating the Samsung TV’s firmware. Now I can watch videos using DLNA without ANY problems.

1 Like

The Mrs tested it Last night with 3 episodes (about 40 minutes long each) and she stated it seemed fine, I will test it further with a movie or something longer and comment back.

I unticked “Restart on NIC changes” on the Twonky user interface.  This seems to have solved it but will report back.

aepr7989 I am completely up to date with my TV’s firmwares, and the issue was still happening, will test over the week and weekend and report back if Fully solved.

Thanks for the Help People.

TonyPh12345 wrote:

Log into the Twonky user interface:


and go to Settings, Advanced, and UNCHECK “Restart on NIC changes” (or whatever the phrase is) and SAVE.


See if that helps.


Glad i browsed the forum today - I have been having the same issue with my Samsung’s! Will try the solution, and will also feedback.

Supert84 - I don’t suppose you have found a workaround for chapter skipping/fast forwarding of video files on the Samsung? On some files i can skip a few seconds with the main navigation arrows, but not that actualy fast forward arrows!?> Any ideas?!

Hello again,

bluenoze22 - I haven’t at all, only thing I can do is press the info button (to show where abouts on the file it is) and then press the fast forward buttons and it seems to work (but need to double check).  I have used the navigation buttons as that doesn’t bother me that much.  Will test further when home.

I tested properly yesterday, and the Twonky server edit Fixed the issue.  Watched a 2.4 hour UFC event without a single disconnect, so happy days, working as it should.  Again for anyone having the same issue, I did as advised which was - 

Log into the Twonky user interface:
and go to Settings, Advanced, and UNCHECK “Restart on NIC changes” (or whatever the phrase is) and SAVE.

After searching High and Low for an issue i’m glad it was solved when I finally asked lol.

Hope it helps others :laughing:

Another thing to add is – keep an eye on that setting change.   I don’t know if it survives reboots or not, but I’m pretty sure it does NOT survive firmware updates.

So after a reboot or firmware update, you might need to re-disable that setting.

Okay looks like my celebrations were premature :cry:

Tested it last night and it disconnected again on the Samsung TV (about 38 minutes in).  I have just seen the last post to see that I should check if the settings have gone back to normal.

I will check again after work tonight.

But all in all very disheartening to know that the 1 MAJOR reason I bought this device isn’t working properly.

Will keep you updated, but as of now…it was solved but for a day, so back to square 1 :manfrustrated:

Okay after vigirously testing over the weekend, I think the issue is FINALLY solved.

I set my TV to a static IP address (easy to do through options) assinged it to the IP address it was, and hey presto no cut outs.

Managed to watch a full movie without it cutting out.

Happy chappy.

Hope it helps others.