Samsung tv can't see all files on wd my cloud

mchung wrote:


I have some media files which are quite visible from my PC but the TVs do not see certain files eventhough they are in Public Shared Videos folder.


When you say “quite visible from my PC”, you don’t indicate which software program on the PC are you using to view or play the files stored on the WD My Cloud. What software program on the PC were you using?

Generally it boils down to the video format (including how its encoded) of the video/media files you have stored in the Public Shared Videos folder and which formats the clients playing that content can support.

On a side note it is recommended to move one’s media files OUT of the Public shared folders for a couple of reasons. See the  [FAQ] Twonky DLNA Media Server Setup & Use guide for more information on using the Twonky media server that is included on the WD My Cloud.


Thanks for your reply.  The file types in question are an MP4, ISO’s and some 4K downloads.  I understand the ISO’s may not be a supported file type.  I have just checked the 4K files and they are all MP4’s.

Thank you


mchung wrote:


 I have just checked the 4K files and they are all MP4’s. 

It appears that Twonky (which is embedded in the WD My Cloud) currently may not properly recognise or handle 4K MP4 files. There have been at least one prior thread, see  here, on the 4K issue. I’ve loaded several 4K MP4 video files and have problems with every single one of them and its either a Twonky problem or a limitation of the DLNA client.


The recent file added was an MP4 ripped from a BluRay using Nero Recode.  I understand that the ISO files may not be supported by the Samsung TVs, but the can happily see and steam other 4K MP4 downloads.

The files are quite visible on the My Cloud using Windows Explorer.

Manuy thanks,



Thanks for your p[ost.

I see the files on the My Cloud in Windows Explorer.  The latest file in question was produced in Nero Recode (Nero {Platinum 2015).

I have even placed a copy in MY Cloud, but still can’t see it.

Many thanks,


the reason why the Windows Explorer can see all the files and the Samsung TV may not has to do with the Samsung TV most likely using DLNA standard to access the WD My Cloud (and the embedded Twonky media server) verus Windows Explorer which is a file management program and which can generally see all files regardless of media type on the WD My Cloud.

The DLNA standard only supports those file types the DLNA server in this case the WD My Cloud/Twonky media server, and the DLNA client, in this case your Samsung TV, can support. There are media formats and encoding/decoding codecs that DLNA does not support.

While you can store ISO files on the WD My Cloud, DLNA clients (like the one your Samsung TV probably uses) will not be able to see and or play the ISO file. You may have to reencode the 4K video or media that your Samsung TV cannot play into a lower standard like 1080, 720, etc and use a standard encoding codec and format. Nero Recode in the times that I’ve used it has a habit of being configured to default to using the Nero proprietary encoding formats which may produce video that is incompatible with some players. As a test use a free program like  Handbrake to reencode the video file into MKV or MP4 and see if the video is playable by your Samsung TV. I stopped using Nero Recode years ago and use Handbrake exclusively for media and ISO file conversion to play on a DLNA media server. YMMV

Hello Bennor,

Many thanks for your detailed post.  When I used Nero Recode I set Nero Recode to the highest quality, instead of the default mid point quality.  Coincidentally, some of the 4K files that the Samsung cannot see are very high resolution files.

Due to occasional previous incompatible MKV’s I decided to produce a MP4 file at the highest quality.  This has probably contributed to the problem with the Samsung.

Whilst I have two WDTV Live units which I have not re-installed at my new home setup could a WDTV Live stream some of these problem files?

I will download Handbrake and rip the Bluray using that.  Do you have any tips for using Handbrake, or is it pretty foolproof?

I appreciate your assistance and will keep you advised.

Kind regards,


To back up what Bennor said:

Windows File Explorer is a File Browser looking at a File Server.

Your Samsung TV has a Media Browser, looking at a Media Server (in this case, Twonky Media Server).

A File Server will allow a File Browser to see any file held by the File Server (provided they’re not marked as ‘hidden’).

A Media Server looks at all the files on a File Server, and checks if it recognises them as media files. It does this by looking at the filename extension, and by looking at the file contents to see if they ‘make sense’ for a known media file type. Having identified certain files as ‘media files’, it will make them available to a Media Browser. It will not make any other, ‘non-media files’ available to the Media Browser.

Due to the huge and ever-growing variety of media file types available, and the different ways in which media preparation tools interpret the (often poorly defined) ‘standards’, a Media Server will sometimes fail to recognise some legitimate media files. Since they’re not identified as media files, the Media Server will not make them available to a Media Browser.


Many thanks for your detailed explanation.  From that am I understanding that different streaming devices, or storage sources may act in different manners?  Therefore something that may not work in one situation may work in another?

Many thanks and kind regards,



Thank you for your assistance with my visibility issue on the Samsung TVs.  After installing Handbrake introduced by Bennor I re-encoded the Bluray using default settings to an MP4 and the file became visible on the Samsung TVs.

I have just played some of the Bluray rip and all is fine except the volume seems a little low using the default Handbrake settings.  Can the audio volume be adjusted and how is this accomplished?

I thank all those who provided posts on my issue and resolution.

Kind regards,


mchung wrote:


I have just played some of the Bluray rip and all is fine except the volume seems a little low using the default Handbrake settings.  Can the audio volume be adjusted and how is this accomplished?

Yes the audio gain can be adjusted up or down from within Handbrake prior to encoding or converting the video file. You may have to experiment to find what audio gain number setting works best. Here are the general steps.

  1. Open Handbrake and load a file or ISO to be converted/encoded.
  2. If needed, select a preset from the right Presets column.
  3. Select the Audio tab.
  4. In the Audio Tracks section select the Show button for the Source.
  5. Adjust the Gain setting either up or down to increase or decrease the audio levels by selecting the up or down buttons. One can also enter a number between 0 and 20 to increase the audio volume/gain, or between 0 and -20 to decrease the audio volume/gain.
  6. Make any other setting changes needed. Note: I always select/enable Web Optimized when doing MP4 files, but it may not be needed. See  this link for Handbrake’s explanation of what Web Optimized is/does.
  7. Begin encoding or converting the file by selecting the Start button, or add it to a Queue by selecting Add To Queue.

Many thanks Bennor,

Your information is greatly appreciated.

Kind regards,


Hi, I’m having this same problem now on my LG Smart TV and Philips Smart TV too!
Seems to be happening after I’ve upgraded my phone to Samsung S7 edge - all the videos taken with the phone and uploaded via WD Photo doesn’t seem to want to show up via DLNA! The files seemed to be of a higher quality than those from my older Samsung phones. Using the phone to edit and saving in a lower quality works, but having to do this for every video is going to be a pain since I take a lot of videos with phones - having growing kids you know . :smile:

Anyone knows of a way to tweak WD My cloud so it will expose these files as well? Since the extensions are “,mp4” as well, I’m wondering how is WD detecting these files and deciding NOT to expose them? Seems like a bug to me given all these new phones are supporting new file formats?

Hi Colin,

I would be keen to hear of any resolution.

Many thanks,

i have the same problem. I am using EX2 Ultra and manny of my MP4 files are there but if i wont play them on my Samsung they are not to find anywere…some of them can i find under MUSIK but they dont play … i used an Netgear NAS befor and all files works… is it posible to get another DLNA player for the WD ??

What? There isn’t ‘a’ DLNA player for the MyCloud; use any DLNA player you like.

What player are you currently using?

Ok…i am not that big PC Champ … i turn it on and it has to work :wink: My problem is that i used an Netgear Networksharddrive before to play all ower videos to all the Pc, Tv, Tablets in the hous. Just for the movies so that we dont have the problems with the twins and the scratched DVD´s - No i got me an My Cloud EX2 Ultra to do this job. I put all the Mp4 files we got at the old NAS to the WD but …
everything is listet in the Public/Share Videos map but - if it comes to the medias we wont to play it with…only a view titels are listet…were are the others gone ??
I read her in the forum that there is a wellknownt problem with the Twonky DLNA Media Server…So - Is it posible to get another media player for the My cloud or is it easyer for me to get me a new Netgear …

Altso my english is not the best…i am danish so …

This FAQ might help you set up the Twonky DLNA media server better. But be aware that it is for the Gen1/v4 firmware basic MyCloud, not the EX2 Ultra, which, if it is a recent purchase, is likely to be running the more recent Gen2/v2 firmware.

I would put the media somewhere other than Public; the default ‘Shared’ locations seem to cause me problems, and you cannot prevent other people modifying the files. Create a Share to put your media in, and only give yourself write permissions.

Then make sure Media Sharing is enabled on that Share, and the Media Server is enabled.

Use the Twonky UI (at port 9000 of you mycloud: :9000) to set the media receiver type; this will tell Twonky what media formats your media players (e.g. TV) can accept.

Thanks for helping.
i solgt the wd my cloude and got me an Netgear (again ) …wupty — all works!

Just wounder why WD not get fixed that problem, i read a lot off that problem on the net and on the German chat side. There are many who have that same problem.
Anyway … Thanks for helping…

( if somebody ask me about the WD … you know what i will say to them - )