Samsung says no video file!

I have a new Samsung UA55D8000 and getting it set up has been fairly easy. It picked up my wifi and identified all the network devises including  My Book Live which has a whole lot of .mp4 videos stored on it in the Shared Videos Folder.

I cannot however get the TV to “see” them – get the message “there is no video file currently available”.

Can someone help me on this please?


Forgot to mention that MBL videos stream brilliantly to the iPad2 via the Air Video Server

Do they work with AllShare?

Well am making some progress  in All Share– have got the video files to show up on screen but when go to open a .mp4 file – says it is loading but nothing happens – have to hard reset the TV. Did actually get a mpg video to play but it was a very squashed picture. The .avi file said it was not supported.

I might be getting a little testy but why should consumers have to go through this battle to get something like this working after all the promotions that say how easy it is to access all your media!!

Any other suggestions would be much appreciated.


Out of interest - the reason why the default font is white is because its easier to read on the blue background.

Tried an .mp4 video on a USB drive and it worked  just fine – brilliant picture.

The exact same file on My Book Live said file not supported!!

So what do you think is going on here?

Really appreciate this help.         

OK tried hardwiring the TV to the network to see if the wifi was causing the prob – still no joy!

On another board a member has pointed out that the USB is probably has FAT as a system file and My Book NTFS – that is correct but what can I change on My Book?

As the MBL is on a network it should make no difference how its formated.

I’m having the same problem! I have .m4v/.mp4 on my MBL, when I find the drive in all share of media player, I can see the videos I want to play. However when I select the video, a screen comes up say “loading” and then after a few min the TV resets. any advice?

 Welcome to the club! I took the cowards way out and simply gave up and put in Apple TV and this works fine.

This is another classic example of a product that is promoted to do something and it simply does not perform. Why should we, the consumer have to go through our individual tech **bleep**? Am not sure which product is the problem here - Samsung or MyBook Live but it is time they got together and sorted it out instead of leaving it to us poor idiots! I wonder if anyone from tech support/production ever reads these posts and if they do - do they do anything about it…