Sample media folder making an issue


I’m still experiencing my new WD TV Live Hub, so here what happened.

I connected the device to my PC through the switcher and I deleted the “sample media” folder, I guess i don’t need it and I will gain some more space on the internal hard drive, but before that I draged the folder to my desktop in case I need it later.

I turned the device into the sleep mode and put some mkv movies from my pc to the internal drive, I went back and I turned on the device, I wasn’t able to see the movies under “files” or under “videos”, i had 0 items. I tried to play the movies from my pc through the network and they are working fine, means the hard disc is ok. I turned off and on the device, still can’t see the movies., it shows 0 items.

I went and I did a “device reset” from the GUI, turned it off and on, finally i can see the movies. Ok, i decided to add more movies, AGAIN, i can’t see the new ones! just the old ones, so I thought maybe it’s because I deleted the “sample media” folder, so I went back to my PC and I put it over the network to my WD internal hdd. Now i can see the movies and even the new ones, I tried to add more and it’s working fine now, I can see every movie i add without even restarting.

I just want to know what is the problem with the “sample media” folder? do we have to keep it? I also want to mention that I did a format for my hdd from the WD GUI after I copied the “sample media” folder to my desktop.

firmware: 2.04.13 “original one” I didn’t do any update.


What if you just unplug the Hub for a few minutes? It needs to power cycle a lot to recompile and recognize new files when added from the network.

1 Like

when the sample media folder is on the internal hard disc, i don’t need to turn it off to be able to see new files added through the network, I can even see that i have more items before the files are totally transferred. Meanwhile if the sample media folder is not there I won’t be able to see them until I do a device reset.

I just wanted to know if somebody faced the same problem or if there any solution for it, because i need to reset the device each time i add files.