When I connect the external hard drive containing my Safepoint and selec the Safepoint on the relevant page of the user interface for Mycloud, the message “This safepoint is in an invalid state, try updating to fix the problem” appears. I then perform an update which seems to proceed OK but the above mesaage is still there after trhe update completes. Do I assume the Safepoint is OK or do I have a problem? The hard drive is a 3tb drive and the Safepoint occupies 1.2tb.

Welcome to the Community.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

I have the same issue.  I almost always get the safepoint in an invalid state message even though it seems to have copied the newest files and removed any deleted files.

I’ve tried a few suggestions like using IE instead of Chrome on PC and Safari & Chrome on Mac.  I can’t pin down exactly what the problem is.  I’m using a MyBook as a backup connected to the MyCloud USB port.

I did notice that when the MyBook is sleeping the safepoint will throw the error message before the MyBook is awake based on the LED light.  I tried waking it up browsing to it in explorer then running the safepoint but still get the error.

There are times I’ll get the error, close the dashboard and browser and reopen and it will then show the safepoint is fine.

Bottom line is I can never be sure if the safepoint is actually working or not.  I’ve got about 800GB now and only have the two WD devices.

Can anyone recommend a backup program that runs on windows until WD gets this sorted out?