Safepoint won't copy files/folders with *, ?, / or | in their names

So, this is my setup:

* A MacBook Pro running OS X 10.9.2 Mavericks.
* The MBP is connected to an Airport Extreme , currently via Ethernet.
* Another Ethernet cable is connected from the AE to a 4 TB My Cloud  (Firmware v03.04-01-219).
* And the My Cloud is connected via USB 3.0 to a 4 TB My Book  (Firmware v1059), partitioned and formatted according to these guidelines (Mac OS Extended Journaled, using the GUID Partion Table).

First, I transfered rougly 2.4 TB of data to the My Cloud without any problems (other than the time it took), and then I set about creating a Safepoint on my newly formatted My Book.

Creating the initial Safepoint took quite a while, but everything seemed OK once it was finished.

But then I noticed some discrepancies.

So I have 1.6 TB of free space on the My Cloud, which seems about right:


And the Safepoint profile indicates that everything has been backed up to the My Book, since 2.3 TB copied out of 2.3 TB on a 4 TB drive would equal 1.6 TB of free space (well, not exactly, but I’d say it’s close enough, taking rounded numbers into account):


However, I noted something was wrong when I clicked on the USB icon in the My Cloud Dashboard:


Now how can I have 2.9 TB of free space on a 4 TB drive if the Safepoint itself is 2.3 TB?

Is my 4 TB My Book a 5.2 TB drive in disguise?

No, checking the drives in Finder on my Macbook Pro confirmed my suspicions.
The My Book had 2.87 TB of free space left, while the My Cloud had 1.52 TB.

So according to Finder, only 1.13 TB out of roughly 2.48 TB had been copied from My Cloud to My Book using Safepoint.
What happened to those remaining 1.35 TB?

Well, after browsing both drives in Finder, I noticed that all the missing files and folders (as far as I could tell) had one thing in common. They all had asterisks (*) in their names.

You see most of the video files on the My Cloud are either DVB recordings I’ve done in EyeTV, or re-encoded iTunes compatible versions of such EyeTV recordings.
In Finder, I’ve used asterisks in the beginning of folder names to indicate that those shows have yet to be encoded.
And I’ve added asterisks at the end of certain file names to indicate recordings that were missing something (say, if EyeTV started recording too late or cut off too early), just to keep track of episodes that I may want to re-record in the future.

But I digress.

So no files or folders with asterisks in their names would be copied from My Cloud to My Book using Safepoint.

I tried renaming one folder, replacing the asterisk with a bullet symbol, and updated my Safepoint.
That file was then copied without a hitch, but all the other ones with asterisks were still left uncopied.

I then tried to copy one of the “asterisk files” manually to the My Book via FInder, and that worked just fine!

Now, theoretically, I could go through hundreds of files and folders and replace all the asterisks with bullets or whatever , but is that really the only possible solution?
Is there a better way?
And how can i be certain that asterisks are the only file-name characters not recognized by my Safepoint?
What if there are more files and folders that aren’t copied?

Any solutions, suggestions or thoughts would be appreciated.

(Sorry for being so wordy!)

Yup; you’re right.

Safepoints rely on Samba, it’s not allowing file names with illegal characters (according to samba, at least.)

Okay. Thanks.

Is there a list of those illegal characters anywhere?

I just noticed that file names with question marks aren’t copied either…


Also noticed that my Safepoint ignores all files or folders with “/” and “|” in their names.

EyeTV routinely uses “/” in its filenames for episode numbering (e.g. “3/16” for episode 3 out of 16), and episode names with “?” are relatively common.

I can’t keep changing all the names manually, so I guess I should look at an alternative backup utility.