Safepoint update failure

Hello,

I recently purchased two 2TB My Book Lives and I have generally been pleased with the devices.  However, I have encountered a problem with the safe-point backup system. 

I am trying to use one of the My Books as a backup repository for the safe-point image (if that is the correct term) of the other device.  I have scheduled the safepoint backups for once a day.  However, a few minutes after the scheduled start of the safe point I get the following error:

"There was an error updating your safepoint Wize_MyBook_backup_11_17_2011 on the Public share on BACKUPMYBOOK.

Severity:warn

Event code:1102"

Has anybody figure out how to resolve this problem.

Thank you,

Chris

I know that the Samba server has issues with Microsoft’s SYNCTOY. After a while Samba on the MBL panics, crashes and is restarted. W.D. told me that Samba is incompatible with SyncToy.

I wonder if the Samba server on your target MBL is crapping out because of a similar problem?

I don’t know enought about the software on the Western Digital devices to know better.  I kind of was hoping it would work out of the box.  Somebody at WD want to answer maybe?

Login to the Dashboard UI.

  • Go to This page:

Support page.jpg

  • Select " Create & Save".
  • Open the ZIP file that is downloaded.
  • Find the file named: wdnas.log
  • Post onto this discussion thread any of the last few lines that seem to show any errors.

Please remember to edit-out anything that, for you, may be private and/or sensitive information.

If you see anything like “Failed to resolve IP address for  target device . . .” then it simple means that the target for the Safepoint back-up can not be contacted. It’s not visible on the network.

Thank you for theadvice.  The last few lines of the log are below.  I got about 1200 entries (not as many files as I actually have on the device) repeating the same “Cannot get permissions for…” error below.

Thanks,

Chris

Dec 13 01:08:51 localhost logger: ERROR: SafeptRunHandler(1787): Cannot get permissions for ‘/DataVolume/shares/Public/Shared Pictures/Chris Photos/2009/01-18-09_1144.jpg’
Dec 13 01:08:51 localhost logger: ERROR: SafeptRunHandler(1787): Cannot get permissions for ‘/DataVolume/shares/Public/Shared Pictures/Chris Photos/2009/’
Dec 13 01:08:51 localhost logger: ERROR: SafeptRunHandler(1787): Cannot get permissions for ‘/DataVolume/shares/Public/Shared Pictures/Chris Photos/’
Dec 13 01:11:02 localhost logger: ERROR: CopyHandler(490): Failed to complete rsync command to copy data - rsync failed with error, 23
Dec 13 01:11:02 localhost logger: ERROR: CopyHandler(521): Failed to copy data from /DataVolume/shares  to /media/WDSAFE/1d9eba6c7aec8cb201508ea24ec5d952//_WDPROT/WDSAFE/Wize_MyBook_backup_11_17_2011/shares
Dec 13 01:11:02 localhost logger: ERROR: SafeptRunHandler(1316): Failed to process shares to Safe-Point  on ‘/media/WDSAFE/1d9eba6c7aec8cb201508ea24ec5d952//_WDPROT/WDSAFE/Wize_MyBook_backup_11_17_2011’
Dec 13 01:11:03 localhost logger: ERROR: SafeptRunHandler(329): Safe-Point Run Failed on handle 1d9eba6c7aec8cb201508ea24ec5d952
Dec 13 01:11:03 localhost logger: ERROR: SafeptInstance(924): Safe-Point Update Failed on handle 1d9eba6c7aec8cb201508ea24ec5d952
Status: FAILED; Failed to complete rsync command to copy data - rsync failed with error, 23
Dec 13 01:11:12 localhost logger: ERROR: safeptExec(1020): OUTPUT Status: FAILED; Failed to complete rsync command to copy data - rsync failed with error, 23

Guess what. Tried to do a SafePoint backup myself last night and got the same similar errors. Same thing, the log does not reveal anything useful to me, but I’ve sent a copy of mine to W.D.

It looked liht it was working.  Did the dry-run and the somewhere along the path of processing the SafePoint back-up it had failed.

I also get the Cannot get permissions messages but it’s not stopped the SafePoint back-up working.

The error you are pointing out looks to be a transfer error of some kind (error 23). The other errors are not issues reported back up through the UI (since you are looking at system logs). Have you tried running the Safepoint again? Do you have network connectivity issues?

(Author removed reply)

I’ll try deleting and restarting the safe point process, but it will take me a couple of days to get it all sorted out.  I’m in the midst of transfering 300 GB to the drive right now.

Please see the other comment in thread “Safepoint backup of 1 MyBook Live to another MBL always fails”

I think we have to act together if we want some results.

I have the issue I never managed to finish savepoint successfully its always failing with

Event code:1102