Safepoint not working since upgrade to Firmware v04.00.00-067

I don’t know where to go with this one.

I have a 4Tb WDMyCloud with a 1Tb WDMyBook plugged into it’s USB socket for backup (there’s only about 500Gb data on the WDMyCloud). Since upgrading to Firmware v04.00.00-067 last night Safepoint no longer works. I get emails from the drive telling me that there has been an error updating my Safepoint. I have tried updating manually without success and even deleted the Safepoint (!) and tried to create a new one. Now I get an error message that says: “Your safepoint cannot be updated due to a failed request. Please try again. (36323)”. Needless to say, trying again doesn’t work!

Everything was fine before the upgrade. Looking around the forum I see that people have previously had similar problems with earlier firmware updates but the only solution given is to ditch Safepoint because it is unreliable. Ultimately this would lead me to ditch both of my WD drives and move everything to my Synology RAID drive which I intended to use only for music. I won’t sleep without a backup!

Anyone else having the same problem?


After the firmware update, did you reset the devices on the network? If not, please try that as the connection might need to be refresh.

How to reset a WD My Cloud

Hello Help4All,

No, I hadn’t reset the devices, but I have now and it hasn’t made any difference. The Safepoint is listed as being in an invalid state and I am advised to update it to fix the error. Clicking “Update” just brings up the error message " Your Safepoint cannot be updated due to a failed request. Please try again (36323)" after a few seconds.

The data appears to have been copied across to the other drive but doesn’t seem to be accessible to Safepoint. Absolutely beyond me!

There doesn’t seem to be a way to fix this. And it’s critical.

I’ve moved all my files onto my Synology and the WD MyCloud is going to eBay.

I had a similar issue with my WD MyBook. The WD hardware is good but the software is inexcusably bad.

I’m in the middle of doing a full factory restore prior to selling and after many hours (at least 24) of writing zeros to the drive the elapsed time counter has now gone back to zero. Perhaps it does this after 24 hours. Who knows? Who cares? I just can’t wait to get rid of the thing.

I know it doesn’t help but they say misery loves company. Thought I had my safepoint problems solved but woke up this morning to find notication of yet another failure on auto update. Am currently running a manual. Am expecting call this afternoon from WD support.  

The other annoying thing is that PC World won’t give me my money back, or even credit. That’ll teach me to stick with Amazon!