Safepoint issue .... or not?

The main downside to using software like Chronosync is the need to rely on a computer to host the software. Remove that computer from the network and the backup/sync no longer gets performed.

One of the good things about Safepoint is it doesn’t rely on any other computer when the USB drive is connected to the My Cloud’s USB port.

If one uses a router that is capable of file sharing (Samba for example) through a USB port on the Router then one could configure Safepoint to backup to the USB hard drive attached to the router.

it’s a USB 3.0, but like you said, it’s not sustained speed. what’s important to me is that I can get a decent transfer speed in the pipeline. waiting 50+ hours to complete 2.6TB transfer is a bit much I think.

i am wondering if the file system of the My Book has any role in this safepoint business ?

for example, the NAS is EXT4, files and folders with permissions/etc. if the My Book FS does not support a verbatim file copy from EXT4, perhaps this is one of the problems ?

Since I access the My Book via a share furnished by the NAS, I don’t think that my Windows or OS 10 care about what FS the NAS and My Book are.

I understand.

to me what’s more important is to have a reliable backup process rather than one that hiccups frequently or doesn’t backup at all (but says that it does).

it’s all being driven by data on my computer anyway - so whenever i need to update the NAS with PC data I do that from the PC with Chronosync. the remainder of the data on the NAS is stationary and doesn’t change. only a very small percentage of the NAS capacity is changed on a daily basis and that is all I need to be backed up on the My Book.

When I am away from home with my PC there is no need to backup the NAS because I do not add or change files on it.

When my pc is home and sleeping, I can configure Chronosync to wake OS 10 and perform the mirror.

I am going to give safepoint 1 more try and watch it carefully over the next few days to make sure it’s backing up properly on the My Book.

A suggestion or two:
Make sure no files on the My Cloud are in use by computers on the local network when the Safepoint is active
Make sure WD Sync or Smartware (or some other backup/sync program) isn’t writing files to the My Cloud while the Safepoint is in progress.
Avoid using the My Cloud at all while the Safepoint is in progress, this includes avoid streaming and remote access to the My Cloud.

the reason for my frustration is because i went out of the way to make sure the drive was not in use with any other ops/devices and i did not even access it from my pc.

spending time too often to fix issues rather than enjoy the content i have on the nas is not something i look forward to


despite the warning notification i got yesterday it appears that the safepoint was created on the My Book and I am going to take some time to test random files in the backup in order to make sure they were copied fully …

in the My Cloud, i set auto-update to on for an overnight backup, but i am perplexed by what actually happened. The time stamps of some directories which I changed on the NAS are as of this morning (on the My Book), however the contents within them are old, time stamps for the files have not changed and new files which i created on the NAS yesterday are not present on the My Book as of today.

there is also a .info file that is dumped in the WDSAFE folder on the My Book, this file is from yesterday when the safepoint was created … I do not see one or any log file for the auto-update.

did not see any notifications in the dashboard either.

I need to find the specific log file on the NAS that lists the activity associated with safepoint updates, which file is that and where can I find it ?

File/Folder on NAS:

SAME File/Folder in My Book:

day 2 now … auto update did not update anything and time stamps of files and folders in the backup are as of yesterday morning.

i did update files on the my cloud last night.

it looks like im just going to grin and bear it for now until ive got my stuff lined up to transition to a synology diskstation. its just a shame i spent this money on wd my clouds and a my book to have the setup i thought was possible but obviously not.

i need robust, reliable and automatic backup of my files. not getting that with wd so far …

Don’t recall if you followed the WD Support suggestions you indicated above of reinstalling the latest firmware and or performing a 40 second system restore. Have you tried one or both of those suggestions?

I don’t have a problem with Safepoint failing to update some files. Seems to work fine.

What specific file types are not being updated? Is it a range of file types or one specific file type (like Microsoft Word files) that are not being updated?

You might look at using rsync instead of Safepoint. nicktee55 developed a script and instructions to do it. I cleaned up his script following the forum changes (but haven’t tested it…), that cause formatting problems that make important characters vanish from posts (#, specifically):

and a follow-up thread from Nick (beware of the missing ‘#’, though):

i did this:

turned off safepoint.
upgraded firmware.
system restore (from the dashboard).
import saved configuration.
rebooted my cloud.
enabled safepoint, created safepoint.
turned on auto-update.

i would really like to have someone please point out the specific log file i need to look at to see whats happening at 2 am when my safepoint is scheduled.

nothing has been updated on the safepoint backup last night.
the previous night time stamps of folders were updated but files inside the folders were not.

i also tried toggling the auto-update switch on–>off–>on last night and setting the schedule prior to the time i set for that to occur.

should not have to be bothered with doing this if the drive is supposed to have a functioning backup routine.

dont want to get into scripting either, its much easier to stay awake long enough and press the update button in the dashboard and see if that works.

I agree. But, in your case, it doesn’t, for some reason; it seems to works for hundreds of thousands of others (despite my earlier comments about not trusting it).

So, you have a choice: get rid and find something else that works (MyCloud > Synology) or get rid and find something else that works (Safepoint > rsync).

You really don’t need all the mail scripting stuff; that’s just a nicety. All you need is something to call rsync, and schedule that into cron.

So, a file called /shares/system/Tasks/, containing

rsync -a /shares/share1/ /var/media/USBbackup/Backup/share1/ rsync -a /shares/share2/ /var/media/USBbackup/Backup/share2/

(change the names to suit, add one line per share)

Then make it executable:

chmod +x /shares/system/Tasks/

Then add it to cron by using the crontab edit operation:

crontab -e

add the line

00 01 * * * /shares/system/Tasks/

This will run at 1am every day (crontab syntax is mm hh dd mo dw command)

if i do it with rsync will the data go directly from the nas to the usb connected device or will it make a trip thru my router and/or pc ?

Direct to USB; running like the small, standalone Linux computer that it is.

one last thing i want to focus on before deciding which other way to go:

is it possible that by importing my configuration back into my cloud after a system restore - that this could be the problem ?

logically it shouldnt. but id like to get to the root cause to find out why first.

i have no problem doing rsync exclusively and bypass safepoint. but isnt safepoint invoking the same thing ?

connected the my book to my pc then checked it with the wd utility:

smart - ok
short test - ok

sleep was set to on. turned it off. then reconnected to my cloud, set the auto update schedule to run overnight.

this morning - nothing updated on the my book.

forced a manual safepoint update and that worked.

so something is not right with the auto-update setting.

neither of these drives is set to sleep they are always spinning.

i might consider trying your suggestion for rsync but i want to make sure the lines are written correctly, perhaps i can get some help ? specifically i want to make sure the paths are correct.

I’d work out what to do by starting small; one subdirectory. rsync can be as fine-grained as you like. There’s plenty of rsync and from documentation on the web; get googling…

You can find the name of your connected USB drive; looks like it will appear under /var/media. Easy to find out:

ls /var/media

You should also be able to put the backup script anywhere you like; in the user file space, for instance, rather then in the NAS OS side (I.e. in a Share). Then you can modify the backup script without having to SSH. Just point to the correct location when you edit the crontab.

it looks like this issue has occured in the past, related to a problem that is likely a glitch in the firmware.

I got some support from WD regarding my issue, pasting it below.

one question I have about this is that I do not modify the files in the backup. could the act of viewing the folders in the backup be making changes to the attributes of the folders maybe ? i do not know if finder is doing that or generating hidden files within these folders ? I also view the backup from windows 10, perhaps it’s doing something similar.

Thanks for your reply,

We were able to read the system log of the unit and appereantly this what we have found:

  1.  My Book is connected to the device successfully

2016-06-08T19:57:26.643902-04:00 di=6ueJSXOABr notice wdAutoMounter[7294]: AutoMounter started
2016-06-08T19:57:46.190904-04:00 di=6ueJSXOABr info logger: INFO: Device added: device=1, vendor=Western Digital, model=My Book 1230, serial_number=575831314432353956505450, revision=1.065
> 2016-06-08T19:58:00.260053-04:00 di=6ueJSXOABr info logger: INFO: getStandbyTimer returned disabled for Western Digital My Book 1230
> 2016-06-08T19:58:00.468176-04:00 di=6ueJSXOABr info logger: INFO: SMART status good
2016-06-08T19:58:09.227411-04:00 di=6ueJSXOABr info logger: INFO: lockState security_off
2016-06-08T19:58:58.376297-04:00 di=6ueJSXOABr info logger: INFO: attached USB partition, reduce inotify limit to: 20000
2016-06-08T20:00:09.274377-04:00 di=6ueJSXOABr info logger:–add My_Book
2016-06-08T20:00:14.987489-04:00 di=6ueJSXOABr info logger: INFO: Partition added: device=1, partition=1, share_name=My_Book, label=My Book, type=ntfs, uuid=92F65979F6595F13

  1.  Safepoint cannot located the metadata file:   var/media/My_Book/_WDPROT/WDSAFE/backup_nas1/

> 2016-06-08T20:05:48.102499-04:00 di=6ueJSXOABr err logger: ERROR: SafeptInstance(3700): 237720987493451774647706867518666666350: Safe-Point is not allocated - metadata file ‘/var/media/My_Book/_WDPROT/WDSAFE/backup_nas1/’ missing

2016-06-08T20:05:48.102661-04:00 di=6ueJSXOABr err logger: ERROR: SafeptInstance(3767): 237720987493451774647706867518666666350: Failed to load Safe-Point Target State
2016-06-08T20:05:48.108616-04:00 di=6ueJSXOABr err logger: ERROR: SafeptInstance(2668): 237720987493451774647706867518666666350: Failed to load Managed Safe-Point State, Status: NOTCREATED
2016-06-08T20:05:48.141875-04:00 di=6ueJSXOABr err logger: ERROR: SafeptInstance(189): 237720987493451774647706867518666666350: Safe-Point cannot be loaded

  1. Due to the missing or faulty file, there is no schedule found

> 2016-06-08T20:18:18.418554-04:00 di=6ueJSXOABr err logger: ERROR: SafeptActionScheduler(255): Schedule Get Failed for action update on handle 237720987493451774647706867518666666350

2016-06-08T20:18:18.418606-04:00 di=6ueJSXOABr err logger: ERROR: safeptExec(1036): OUTPUT Status: NOTFOUND; Schedule not found for action ‘update’ on handle ‘237720987493451774647706867518666666350’
2016-06-08T20:35:22.331471-04:00 di=6ueJSXOABr err logger: ERROR: SafeptActionScheduler(212): Schedule not found for action ‘update’ on handle ‘237720987493451774647706867518666666350’
2016-06-08T20:35:22.331974-04:00 di=6ueJSXOABr err logger: ERROR: SafeptActionScheduler(255): Schedule Get Failed for action update on handle 237720987493451774647706867518666666350
2016-06-08T20:35:22.332047-04:00 di=6ueJSXOABr err logger: ERROR: safeptExec(1036): OUTPUT Status: NOTFOUND; Schedule not found for action ‘update’ on handle ‘237720987493451774647706867518666666350’
2016-06-08T21:05:00.669122-04:00 di=6ueJSXOABr err logger: ERROR: SafeptActionScheduler(212): Schedule not found for action ‘update’ on handle ‘237720987493451774647706867518666666350’
2016-06-08T21:05:00.711831-04:00 di=6ueJSXOABr err logger: ERROR: SafeptActionScheduler(255): Schedule Get Failed for action update on handle 237720987493451774647706867518666666350
2016-06-08T21:05:00.751370-04:00 di=6ueJSXOABr err logger: ERROR: safeptExec(1036): OUTPUT Status: NOTFOUND; Schedule not found for action ‘update’ on handle ‘237720987493451774647706867518666666350’

This basically means that it is unable to update since files on the external drive are being modified which means (renamed, delete, change or edit) any of those files on the my book drive.

Please keep in mind that a safepoint is meant to do a copy from one location to another, now the files should not be modified at any moment because by the time the schedule feature will start will not find the original files and that’s why it will not apply the update.

Please create a safepoint and set it up to scheduled and make sure you do not modify any files and it will take the update. Now if you need to modify files for any reason then you need to do it manually the update.

just a bit wierd that a manual update works fine but an auto-update does not.

i dont want to un-map the my book because i want to see that files were updated.

in my experience the dashboard had notified me that an auto-update completed sucessfully but in reality nothing was updated on the safepoint backup, so i cant really tell otherwise without viewing the backup folders.