Safepoint and Time Machine backups not working

I have a powered USB four port expander attached to my 3TB My Cloud with two external hard drives attached to the expander, both are formatted as Mac journaled. One is a Seagate 2TB hard drive I want to use for Time Machine backups for both my Mac using OSX 10.9.3 Mavericks and my Macbook pro laptop. I also have a 3TB Toshiba external hard drive HDWC130XK3J1 attached to the hub I would like to use for safepoints.

The time machine backup will not keep the settings I have saved for it several times over. If I want to do a time machine backup on either of my computers I have to log in to the administrative interface and set it up every time.

My safe point worked once on the 3TB Toshiba drive. I had set it up to do backups automatically but that never worked I kept getting error messages. When I do it manually through the administrative interface and click “Update” I still get an error:

Event title:There was an error updating your safepoint.
Event description:2 - There was an error updating your safepoint (mycloud name) on the safepoint share on (mycloud name)               Severity:warning              Event code:1102               Event time:06-17-2014 10:43:22 PM
 Firmware version: 03.04.01-230

Ever since I got my WD MyCloud for Christmas 2013 I have put more time into troubleshooting than using it. If I cant back up my computers and or the cloud itself there is no point in having just another external hard drive and this is what happened beofre and I turned it in for a replacement. I have done a factory restore and it did not help, I have the latest firmware 03.04.01-230.


I recommend you contact support directly.

Personal Cloud Support

Funny thing is when I do a backup it gives me the error but the reality is it does back up. I have tested and checked it several times and it does actually copy the new files I have added since the last safepoint. Wish I would not get an error message but at least it is working and that is important. No sense in having the cloud if I can’t back it up so I will wait for a fix and reply from support which I emailed a few days ago.