"Safely Remove Hardware" won't work on Passport Essential 750GB


#1

Can this be solved?

When I try to “Safely Remove Hardware” my passport, I get a message telling me that the drive is in use and I must try again later. The drive is not used. All applications are closed. Why do I get this message? I have to shut down my computer in order to be able to disconnect this drive.


#2

If you are using Windows XP/Vista, then please follow the steps below:

Connect the External drive to the computer.

Make sure you close all the applications and screens

Right Click on Mycomputer/Computer, then click on manage.

On the Computer Management, Click on Device Manager and then select Disk Drives.

Right Click on the External drive and select properties.

On the properties screen, select ‘Policies’.

Now Click on “Optimize for Performance” and Click on OK.

You will get the screen to restart the computer, Click on Restart to make the necessary changes.

Once Windows is back, now use the Safely remove to unplug the drive. It will work.

Note : Following the steps above will not cause any damage / harm to you computer.


#3

OK. Thanks for the tip. I had this issue on my home computer and I will be home only thursday night so I will not be able to try that until tomorrow. I did not have this issue on my office computer.


#4

It happened to me with WD esential mybook 1T.

I read  lot of replies all over the web and one of them said that the antivirus SW ( he used AVG) caused this problem.

I recalled that I have new ESET NOD32 antivirus revision 4 which scans my computer on statrtup as well. As soon as I uncheck this operation on ESET scheduler , the problem of saftey remove HW was resolved.

I asked ESET to find our the cause and I have been waiting for their response.

The guy who posted about AVG reported that there was no problem with the new version ((9).

Hope I helped.


#5

Is there a solution to this? at 1st i have no problem accessing the Safely remove My Passport essential using a 320GB

with an installed Avast antivir.

Using a Win 64bit, now im getting the problem with the WD software safe remove also i cant remove also either on Windows Safely Remove Media.

Ive try to disable the Avast antivir still the same, i also try to close all programs reboot pc on taskbar still the same nothing works.

is there been anyone can help me? thanks.