Safe shutdown

I was talking about the gen 2. How can the WD accesses turn the My Cloud on? Of not
wake on lan. Does that mean it will turn on a gen 1 My Clloud?


My guess is that much like the Gen 1 My Cloud, one cannot turn the Gen 2 My Cloud back on with WD Access once turned off. In one of the links I provided above a user of a Gen 2 My Cloud dumped the info from the NIC and it indicated wake on lan was not supported.

The WD Access program doesn’t have the option to turn the Gen 1 My Cloud back on once turned off as evidenced by the two screen captures below. First screen capture shows the option to Shut Down, the second screen capture shows what options are available once the My Cloud is shut down. The only solution is to power cycle the My Cloud to reboot it.

Tulak What model are you turning on and off?


I use
My Cloud Mirror 4 TB

I use a batch file now to shut down but for months, I just shut off the power strip it was plugged into with not one problem at all.

The single bay My Cloud and the My Cloud Mirror are two different devices with different features and possibly different hardware. Supposedly, if this post is correct, the Mirror doesn’t support Wake-On-Lan, but the EX2 does. Per that thread (in a following post) the Mirror can be “woken up” somehow.

Obviously when the single bay My Cloud is shut down it still draws power as the back LAN port is still active. Does this mean there is some way to wake the unit up after triggering/issuing the shutdown command? Don’t know. Would be nice if there was.

As I sad My Cloud Mirror with WD Access software I am able wake up and turn off.
As you pointed out yes “My Cloud and the My Cloud Mirror are two different devices” old and new!

Here is my setup: My Cloud Mirror is connected to router with Ethernet cable same is router and PC.
Even before when router and PC was running WI FI it worked too.

Using a gen 1 My Cloud connected to a broadband gateway on the local network.

The inability to “wake up” a single bay My Cloud has been discussed in the past in several earlier threads as mentioned above. Its an issue that comes up from time to time. While the Mirror may have the option to wake up the My Cloud Mirror, currently the single bay My Cloud units do not. Currently the only way is to power cycle the single bay My Clouds. Don’t recall if anyone with a 2nd gen single bay My Cloud has indicated if the wake up option in the Mirror is also present in the 2nd gen units. All I’ve seen is the NIC info dump mentioned above that someone else did from a 2nd gen My Cloud that indicates the WoL option is not present on the NIC.

I connected to my My Cloud via SSH. Unfortunately I don’t have a shutdown file in my /sbin/ folder. All I have is /usr/local/modules/script/ Any suggestions?

The above directions for using SSH to shutdown or reboot the My Cloud are for v4.x firmware My Clouds. Unknown where or if there are similar commands to shutdown/reboot the v2.x My Cloud units. There probably are similar commands for v2.x versions, but since I don’t have a v2.x My Cloud I have no way to find out.

As indicated above, one can use the WD Access program ( which does have the option (at least for v4.x versions) to shutdown the My Cloud, see my post above on Feb 16 for screen captures indicating that.

I tried to execute that file and fortunately it works! So if anybody wants to shutdown a v2.x WD My Cloud you could use that command. I’ll try that WD Access program although I actually need a possibilty to shut it down from a mobile device!

If only it had WOL functionality. I’m probably going to buy a remote power socket and do it as follows:

  1. Use SSH to shutdown device.
  2. Use remote to disconnect it from power.
  3. Use remote to connect it to power and it hopefully will boot!

WD Access for Mac has no shutdown functionality!

My system with the latest version of 4.x firmware has /sbin/shutdown and /sbin/reboot and /sbin/halt


Yep, as Bennor already said: the above instructions are only for the slightly older Generation 1 with v4.x F/W.

Thanks for the suggestions, WD Access allows me to shutdown the device. Not perfect as this should be in the we UI but it works.

File under: “What WERE they thinking?!!”

I tried that, and it appeared to shutdown the system - including a power-off. However, when I turn the thing back on, there is a warning message in the webmin page saying that power was lost and it’s doing a consistency check of the filesystem. Therefore my understanding of what happened is that the filesystem is NOT cleanly unmounted prior to powering off the system, leaving the filesystem in a potentially un-defined state. :skull_crossbones::skull_crossbones::skull_crossbones::skull_crossbones:

Ergo, I am forced to believe that someone, somewhere, made a serious balls-up of the 2.n firmware.

BTW, the WD Access software does not, repeat NOT include a “shutdown” option for this item.

I totally get what people say when they mention that a device like this is designed to be on 24/7. However, I don’t care - even gazillion-dollar-each servers rated for “six nines” uptime still have a blankety-blank-blank power switch!

Seriously folks, there will be times when you need to turn it off in a safe manner.

If I wasn’t being shipped overseas in 48 hours-or-so, I’d seriously consider wiping the device, returning it, and look for a device with the 4.n firmware in it.

This isn’t just crazy, it’s stupid. More than that, it’s carelessly stupid.

(Shaking head in wonder)

Jim “JR”

(insert picture of head with top blowing off and steam coming out of both ears)

File this one under “Give 'em a SMACK!
(Subcategory: We’ve been making this WAY too hard. . . .)

A bit of research has discovered two things:

There is a very, very, useful utility called WinSCP that will allow you to securely move files from - and to - your My Cloud device using your existing SSH credentials.

Having used this utility to poke around and download a few files, I discovered a hidden gem.

The My Cloud, with the 2.n firmware, has a cleverly hidden command named, (Doh!) “halt”.

This command, (which is a binary), when run from the SSH command-line does a full, formal, and complete shutdown of the device, including un-mounting all the filesystems in a sane manner.

Strangely enough, this appears to be totally un-documented - that is until right now.

So, go fire up those SSH clients and have fun shutting down your My Cloud boxes!

Jim “JR”

Yes WinSCP is a useful utility. It is one often mentioned in this subforum as an alternative to Putty for Windows users and can be used to move/copy/delete and more importantly edit files in the My Cloud OS.

What is the full path to the Halt command on the v2.x? Users may need to know the full path to Halt in order to program a batch file to use a SSH program like Plink, included with Putty, to issue commands without opening a command line terminal window or when using certain apps or software.

Next, when issuing the Halt command is it doing a full shutdown or just terminating the processor? And post Halt are the LED’s on the NIC still active? With the first gen My Cloud’s there is still power going to the NIC port post shutdown as the LED lights are still active. Before anyone asks the first gen My Clouds apparently do not have Wake-on-LAN capability which has been mentioned in several other prior discussions.

WD made some compromises and frankly a stupid programming mistake that has so far gone unfixed with both versions of the single bay My Cloud units. The lack of a physical on/off button is one. The lack of a method to power on the unit though Wake-on-LAN or similar action once a shutdown has been performed (at least on the first gen My Cloud) is two. Right now one has to physically power cycle the My Cloud. And the lack of a shutdown button in the v2.x firmware second gen My Cloud units even though its mentioned in the manual twice is three.


At least on MY single-drive My Cloud with the 2,n firmware, the “halt” command fully shuts down the device. Period. No lights. No network lights. No apparent disk activity.

The clincher:
When you use the “” script, it appears to shut the system down, but does not formally un-mount the drives, completely turn off power, etc. The result is that when you restart and log into the Dashboard, (what I cal the webmin page), you get a red alert claiming that “power was lost” and that it is “checking the file-system’s consistency”.

When you use the HALT command, the lights flash, the system goes to a totally power-off state, (the network lights are not running), and the filesystems are formally unmounted. This is shown by the fact that - when the system is re-started and you then login to the Dashboard - you do NOT get a “Power Failure” message, you get a “The system is booting. Please wait” message, and there is no alert in the alerts page for a power failure.

I suspect that the “shutdown” script does not really shut down the device, but rather puts it to sleep with the network and a basic level of functionality active so that it can “wake on lan”. By comparison, the “halt” command appears to completely shut the device down to a completely powered off state.

I do not remember where the actual path to the “halt” binary is. However it is in the system’s path, so that it will run regardless of where you might be in a SSH session. I do remember it is somewhere around the " /usr/local/modules/" area in the filesystem. Regrettably, I may not have the time to go find it for you.

I have not tried using something like Plink, but if Plink can send commands to a SSH-like session, it should work automagically as it is in the path. YMMV.

My investigations within the " /usr/local/modules/" path disclosed that there IS programmatic support for Wake On Lan, it just appears to not be implemented properly. Again, like the (hidden) halt command, I suspect it is just a matter of finding out how to use it. (Note that my investigations are being done with a single-drive, version 2.n My Cloud.)

It’s stuff like this that makes me wonder if the Dev team from WD were hired away from M$, or went to the “M$ School of Programming Excellence”. Likewise the QA department.

In all the SQA assignments I have had in the past, releasing with what are obvious high-severity bugs like these would have gotten me tossed out the door on the tip of the manager’s #9, steel-tipped boot!

The ray of sunshine in these clouds is the existence of fora like these, and people like us who are willing to take the time and research these issues with a view toward solving - or mitigating - them.

For which I am gratefully and humbly thankful.

Jim “JR”

Note that on my v4.x My Cloud the halt command (halt or halt -p) does not completely shut down the device either. Like with the shutdown - h command the NIC port remains powered.

Further I do not get an error message about a power failure post restart when using shutdown -h, I get a system restarted message with v4.x firmware.

There are slight differences between the two My Cloud firmwares which is why I asked where the halt command was located on the v2.x My Cloud since I do not have access to a v2.x My Cloud to find out the differences in file structure. The v4.x firmware is Debian (Weezy I believe). And the typical way from the command line interface of Debian to shut the system down is to use one of the following: shutdown -h now, halt, or poweroff.

I have also found this error and noticed where the problem is: the CSS is hiding the button.
The following screenshots prove it.
Meanwhile I’m ssh’ing and “ -h now”.
Hope this helps both the users and the devs!

1 Like