Rsync transfer question


I have two machines, one WD My Cloud 4TB and one Windows WHS 2011 Server, where I have a few shares that I want to keep synchronized. The WD My Cloud is located at my brother’s house and I have a VPN connection between both locations. I have Cygwin rsync on the Windows WHS 2011 Server.

 I configured the WD MyCloud using ssh as described here:

So I’m running the rsync daemon on the WD My Cloud and initiate die transfer from the WHS Server.

I run this with options –rtcv  as the owner and group are different on the WHS Server and I just don’t want to copy the original ownership.

Basically the transfer works, except for:


I don’t get the file permissions set as I want it. It is always  ‘drwx------ 25 root root’. I want to have it the same as the shares folder where I write in which is ‘drwxrwxrwx 25 root root’.

How do I do that?


Is there a way of not needing to prompt for a password without using ssh? I have a VPN in place and don’t need a ssh connection.

Kind regards,


For item B see:

So there is no option without using SSL? I don’t need it as I have a VPN between the locations. I heard, it slows the transfer down due to cpu load. Any way to pass the password as a parameter?

Well what you are wantng is rsh then, but I do not know if you can get it for the MBL as I have never tried it.